• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
Pumpkin drop event

Weird Motor issue?

TexasTeacher

Ready to Crash
#1
Ok guy this has started happening recently. It happens without any input and when you do give it input the right front motor spins up much faster than the left rear and the quad flips. any help would be great. I have redone the firmware on the FC and still the same issue. Towards the end of the clip, I do blip the throttle and then I cut it just so it did not self destruct there on the table

Take a look:
 

TexasTeacher

Ready to Crash
#4
Sorry for the slow response but school is getting crazy

That is weird. Have you tried recalibrating the ESC's?
I have tried that including completely reflashing the FC
Did it fly correctly at some point and this developed, or is this a new build?
It did fly correctly at one point, actually really well, had a crash and now is doing this. I have checked everything i can think of and seems to operate correctly when on the computer
 

ElectriSean

Eternal Student
Mentor
#5
Slowly ramping up on the bench with no props on is pretty normal, flipping out with props on isn't ;) Are you sure all your motor directions are correct, and you have the correct props installed properly? Does it flip out in acro (rate) mode, or just in angle or horizon?
 

TexasTeacher

Ready to Crash
#6
Slowly ramping up on the bench with no props on is pretty normal, flipping out with props on isn't ;) Are you sure all your motor directions are correct, and you have the correct props installed properly? Does it flip out in acro (rate) mode, or just in angle or horizon?

I will check the props and motor directions again.
 

kpixels

Antigravity or bust...
#7
If you haven't already, try to calibrate the accelerometer. They can get knocked silly in a crash and don't know which way is up.