Solved Can't get tail servo working properly on tricopter...

Aerobot

Junior Member
Does this mean I'll have to downgrade cleanflight to connect to the FW on my naze32 rev 6 board or the matek f405 STD?
 

LitterBug

Troll Spammer
One thing to remember is that TriFlight is just add on functionality that the DEVs have added in to another flight controller software. Wether it be OG CleanFlight, BetaFlight, Cleanflight rebased from BetaFlight, iNav, dRonin, or something else, it adds feedforward to the tail servo to help reduce the yaw lag, overshoot, and other effects caused by the movement of the rear motor.
 

Aerobot

Junior Member
BTW, I think I've found a forum post by jihlein that tells me where to land the feedback wire from the servo: For the servo feedback wire, you have to connect it to the RSSI ADC pin, and choose ADC2 in the TriFlight setup parameters.

I think I'll have to load dRonin [2018-07-29 release ("Inconceivable")] and connect it to my NAZE32 rev. 6 and go from there.

@LitterBug - is this the right approach?
 

LitterBug

Troll Spammer
Plausible... I will check my dRonin versions and get you the one that worked best for me. JIhlein had a stripped down "lite" version for the F3 boards. I still keep in touch with him.

Have had best results with the .5 version of the TriFlight added in. The .7 triflight had awful yaw oscillations on the ground after arming, and annoying slow yaw oscillations while flying FPV.
Video feed from one of my Baby Tricopters when doing some testing a while ago. Had bad yaw oscillations on right turns but rock solid almost everywhere else.
 
Last edited:

Aerobot

Junior Member
Was that video captured with the baby tri using the .5 or the .7 version of TriFlight? I too saw those oscillations on the .7 Beta 3 version and re-flashed .7 Beta 1 as a result. I didn't know if the .5 version included the servo tune and auto tune functionality - and I definitely want to be using those features.

BTW, great video.
 

LitterBug

Troll Spammer
Was that video captured with the baby tri using the .5 or the .7 version of TriFlight? I too saw those oscillations on the .7 Beta 3 version and re-flashed .7 Beta 1 as a result. I didn't know if the .5 version included the servo tune and auto tune functionality - and I definitely want to be using those features.

BTW, great video.
That video was .5 based and on dRonin. Servo tune has always been part of the triflight code. Autotune is a dRonin feature that is not on the cleanflight/betaflight variants.

.7 added some sort of additional gyro and/or accelerometer feedback which caused side affects that for me negated any gains that may have been made.
 

Aerobot

Junior Member
Tried and tried, but I can't seem to get a hex FW of TriFlight 0.5 for my Matek F405-STD FC. Does one exist? Do I use LibrePilot, BF, CF, dRonin to flash it? I was ok with the TriFlight 0.7 B1 running on my naze32 rev. 6, but I'm so limited with uarts. Thoughts?
 
Last edited:

LitterBug

Troll Spammer
Tried and tried, but I can't seem to get a hex FW of TriFlight 0.5 for my Matek F405-STD FC. Does one exist? Do I use LibrePilot, BF, CF, dRonin to flash it? I was ok with the TriFlight 0.7 B1 running on my naze32 rev. 6, but I'm so limited with uarts. Thoughts?
Been very busy with family this week. Hope to get back on this tomorrow.
 

Wolvreene

New member
Hi everyone I have a problem with my tricopter at can’t get it to take of its flips violently every time I try to flight, I sow slot of video on YouTube I sheqrchzd on goggle but no luck
Kk2.1.5 turnigy plush sunysky motors 1240kv
I tryed changing the board and motors and still the same problem anyone can help please? Thank you
 

Aerobot

Junior Member
Hi everyone I have a problem with my tricopter at can’t get it to take of its flips violently every time I try to flight, I sow slot of video on YouTube I sheqrchzd on goggle but no luck
Kk2.1.5 turnigy plush sunysky motors 1240kv
I tryed changing the board and motors and still the same problem anyone can help please? Thank you

@Wolvreene , I would be sure that:
  • (Before you mount any props...) Be sure that the motor on the tricopter that spins matches the motor number in your GCS (Cleanflight, Betaflight, dRonin, etc.) - check this by applying power to each motor separately. If you simply have the KK2, then plug in one control wire at a time pertinent to each motor.
  • Your props are mounted properly (CW, CCW)
 

Wolvreene

New member
@Wolvreene , I would be sure that:
  • (Before you mount any props...) Be sure that the motor on the tricopter that spins matches the motor number in your GCS (Cleanflight, Betaflight, dRonin, etc.) - check this by applying power to each motor separately. If you simply have the KK2, then plug in one control wire at a time pertinent to each motor.
  • Your props are mounted properly (CW, CCW)
I’m using a kk2 board wich doesn’t need computer.all settings are on board .
Yes props are mounted properly.
 

Aerobot

Junior Member
As @LitterBug mentions: do you have the arrow facing to the front of the tricopter? And, double check that your setting (see below) matches that orientation on the tricopter frame.

From the KK2.1.X manual:

Board Offset (see Appendix H)
  • 0 – Zero degrees offset. KK2.1.X board faces forward.
    • +45 – KK2.1.X board is mounted 45 degrees clockwise (top left corner points in direction of flight).
    • -45 – KK2.1.X board is mounted 45 degrees anticlockwise (top right corner points in direction of flight).
 

Wolvreene

New member
As @LitterBug mentions: do you have the arrow facing to the front of the tricopter? And, double check that your setting (see below) matches that orientation on the tricopter frame.

From the KK2.1.X manual:

Board Offset (see Appendix H)
  • 0 – Zero degrees offset. KK2.1.X board faces forward.
    • +45 – KK2.1.X board is mounted 45 degrees clockwise (top left corner points in direction of flight).
    • -45 – KK2.1.X board is mounted 45 degrees anticlockwise (top right corner points in direction of flight).
This is how I mounted it. I had a previous tricopter wich I sett the same why but the bastards stole it from my car
 

Attachments

  • image.jpg
    image.jpg
    2.4 MB · Views: 0