• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Configuring Betaflight for PPM

Hello all,

This is a complete newb question, but how do I set up a betaflight receiver for PPM? I have the signal cable in the proper ppm/sbus port, and I have set the receiver mode to PPM Rx in the betaflight configurator. I still can't get it to work. Are there any steps I am missing? I am using a FLIP 32 F7 Omnibus V2 fcb.




Construire Voler S'écraser Répéter
Iondriver, the PPM setting is in the configuration tab in betaflight. See numbers 1 and 2 -

Also, in the future, you can keep replying with new questions in your old thread. You don’t need to create a new thread.
Last edited:


Eternal Student
Iondriver, the PPM setting is in the configuration tab in betaflight. See numbers 1 and 2 -

You also need to set UART1 to serial Rx in the ports tab
Actually, only serial receivers like SBUS and Spektrum satellite need to have a UART set up.


Construire Voler S'écraser Répéter
Thanks, Sean. That’s what I had initially typed up, then I got caught thinking that PPM one wire was serial.
Ok, thanks everyone for the info! This is my first build, and I ended up with an fcb that didn't have very good documentation or labeling.

I think I found the sbus/ppm jumper, but I would like to make sure. Is it the part I circled in red at the bottom of the picture? If it is, what parts do I jump?

InkedFlip32 Omnibus F7 FCB wiring_LI.jpg


Construire Voler S'écraser Répéter
I think what you’ve circled in red are the USB pads. I wouldn’t jumper those.

SJ2 may be a jumper, but I can’t tell what’s its for...
I really hope that is not the case. If it is, it looks like I will need to get a PWM harness. I am using an FrSky i6S, I believe. I will double check as soon as I get the chance. I know it is a 6 channel FrSky receiver with telemetry, and a combo ppm/channel 1 port.
I do! I now have the receiver hooked up, and it works properly in the beta flight configurator. Also, is there a way to change which channel is the throttle?

Thank you for everything French, I greatly appreciate it!

Edit: I forgot to mention that I have tried to adjust the channel mapping using the menu in the transmitter. Right now the throttle is set to left/right motion on the stick, but I would like it to be up/down.
Last edited:


Construire Voler S'écraser Répéter
Great! Channel mapping is an easy one. Just got to the receivers tab in betaflight and choose the one for you (top right)

TAER means - Throttle on channel 1, Aelieron (roll) on channel 2, Elevator (pitch) on channel 3, and Rudder (yaw) on channel 3.
You can change that drop down until everything is right on the screen.

Also be sure your directions are correct (lowest value at stick down or left position, then highest value at up or right). Lastly make sure your springy sticks center around 1500, your low stick positions are at 1000 and your high stick positions are at 2000
Cool! thank you!

One more question. When I test the motors using the Betaflight configurator, my ESC arms properly. When I try testing the motors using the transmitter, the esc doesn't arm. I get the first three beeps from it, and that is it. Do you have any idea what could be causing it? I am using a RacerStar 4-in-1 ESC with BLHeli. Here is what I have configured for the ESC's so far. My receiver has a self centering throttle. Could this be causing it?

Betaflight - Configurator 11_3_2017 1_22_58 PM.png


Eternal Student
My receiver has a self centering throttle. Could this be causing it?
Yup, when you boot your ESC at some point higher than 1000ms (zero throttle) it goes into programming mode. You should probably ditch that throttle centering spring, I can see it causing huge problems other than this.
Ok, so the self centering throttle wasn’t the only issue apparently. I successfully removed the offending spring, and the throttle responds correctly on the configurator. However, I am still having the same issue. What are the typical causes of this problem?
Ok, I have what should hopefully be my last problem. When I try to get my quad to take off, it rolls sharply to the left. This happens when I set it on the ground, or hold it in my hand. I have troubleshot it to the best of my abilities, but I haven't found a solution yet. Here is what I have double checked:

*Motors are in the correct positions
*Motors are spinning in the correct direction
*The proper propellers are attached to the appropriate motors with the text facing up
*All motors activate at the same time and move at the same speed
*My PID settings are default.
*My minimum roll is 1000, the middle, where the stick naturally rests is 1500, and the maximum roll is 2000
*Moving the roll stick to the left decrease the value, and moving it to the right increases it
*I have the default QUADX motor mix.
*The accelerometer is correctly calibrated.

I have attached a picture of my current PID settings which are the default for beta flight. Does anyone have any ideas as to other possible causes?



Betaflight - Configurator 11_5_2017 2_43_10 PM.png
Last edited:


Construire Voler S'écraser Répéter
When you go to the Setup Tab and move the quad around, does the quad on the screen correspond to your movements? Pitch forward, pitch back, roll right, roll left, yaw (spin) left, yaw right?