• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
Pumpkin drop event

Desperately seeking help on FT explorer 3 ch servo repair

Raycefan

Junior Member
#1
I have not even flown its maiden yet and as I put it I the car the elevator catches the back seat and i hear a loud pop. Now the servo and elevator move freely. I’m thinking stripped or thrashed servo. If there’s a way to get at or change out that servo without butchering this nice knew foam board body I just so tediously made, I’d LOVE to hear it, thanks.
 

Bricks

Well-known member
#2
If you used hot glue to install the servos you can used denatured alcohol to get them loose. For the wire unhook from the receiver and te a string to it so you can pull the wire out and back in.
 

Raycefan

Junior Member
#5
The good news is, I maidened it yesterday, glitchy servo and all. And it flew just fine...until After about a 5 minute flight, I increased the throttle to full, and promptly buckled the wings in half.
 

Raycefan

Junior Member
#6
If you used hot glue to install the servos you can used denatured alcohol to get them loose. For the wire unhook from the receiver and te a string to it so you can pull the wire out and back in.
So, I’ve tried this before, and it seems to always delaminate the paper from the foam board.
 

FDS

Well-known member
#7
You can use a hairdryer to soften the glue then remove the parts. That’s how I fix my stuff.
The wing can be reinforced a ton of ways, there’s numerous threads on here if you search. It’s not a stunt plane tho so if your throttle thumb is heavy you might want to look at setting up a softer throttle curve in your TX.
Well done for surviving the maiden.