• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Turnigy 9x and a sim

buzzbomb

I know nothing!
#1
So I've got the Turnigy 9x Trans. I've got the 22 in 1 with RealFlight 7 and Phoenix 5.0b. I can't get either sim to recognize my trans, even though it's plugged in to the training port and the usb adapter that came with. I've flipped the "training" switch both ways, I've tried plugging, unplugging ad nauseum. I created a new plane, but the darn thing won't save it. I've gone through the excruciating naming process four times.

Anybody with ideas or experience, please chime in to help.
 

d8veh

Well-known member
#2
When you put the disc in, did you load all the software from the menus that appear? You don't have to load everything, but IIRC you have to load the ones at the top of the list that includes the dongle drivers.
 

buzzbomb

I know nothing!
#3
When you put the disc in, did you load all the software from the menus that appear? You don't have to load everything, but IIRC you have to load the ones at the top of the list that includes the dongle drivers.
No. I only loaded the flight sims. Windows said it recognized when I plugged in the trans, but it recognized it as a game controller. Both sims won't work with a game controller.

Going to uninstall and reinstall. I'll let you know.
 

d8veh

Well-known member
#5
Third one down. Install driver. I installed the first one too - Install switcher.
Note that there's a switch on the dongle. You have to set it in the right position for whichever software you're using.
I'd forget about RealFlight for now. Just install Phoenix because you can download all the FT planes and it works extremely well.
 

d8veh

Well-known member
#6
Windows might get confused which driver to use if you've already let it install one. Unplug the USB dongle. Install the correct driver from the disc, then plug in the dongle to a different USB socket. If you check your Device Manager, you should see it as something like "HID compliant vendor defined device".

In the model setup in your transmitter, you must set it to PPM mode.

One other thing I found out is that some people wanted to use the transmitter with the RF module removed. I don’t know whether it doesn’t work unless you do that, so, after trying everything above, if it still doesn't work, unclip the RF module from the back of the transmitter. Be careful because it might be still connected by a wire, in which case you have to leave it dangling or taped to the side of where it normally sits. There's a simple modification to solve that. I don’t know whether that's only a problem of older versions of the transmitter.
 

buzzbomb

I know nothing!
#7
OK. I took your advice and kind of ran with it. In Device Manager I found no game controllers other than my graphics card. I did find many unrecognized usb devices that were controllers. I removed what seemed to be the most relevant, they all went away.

I did a reinstall of the Phoenix 9x driver (I thought the button was just to install Direct X 9. Doh!) Then I unplugged everything, and plugged the controller into a different usb port as you suggested. Lo and behold, Phoenix recognized I had a controller plugged in.

It's "nearly" calibrated. I can't get the left/right on the trans right stick to have any effect. Phoenix won't recognize any of my switches and the flaps on the right side of the model are always down. I can't take off.

If it means anything, I'm just using the default model that the sim starts with. I'm just trying to get the right-side flaps straight, so I can take off. Yes, I've re-calibrated. No, it didn't help. Phoenix just doesn't seem to recognize the right stick, left to right movement and the flaps are down on the right side of the model.

It's just an update. Working on it.
 

d8veh

Well-known member
#8
It's a while since I did it, but IIRC the things that you need to do are:
In your transmitter, make a new ,model. Set the protocol to PPM;
In Phoenix, use the transmitter profile wizard;
After that all transmiter settings are done in Phoenix, like servo reversing for controls that work backwards.
 

buzzbomb

I know nothing!
#9
It's a while since I did it, but IIRC the things that you need to do are:
In your transmitter, make a new ,model. Set the protocol to PPM;
In Phoenix, use the transmitter profile wizard;
After that all transmitter settings are done in Phoenix, like servo reversing for controls that work backwards.
Solved. I'm going to recap a bit and go into a little detail, for the next guy.

The trans kept losing my settings for everything. Including PPM. I finally figured out that was because during my troubleshooting process I kept changing the model type between helicopter which is what the Phoenix manual said it to had be and airplane because that's what I was trying to fly.

With the Turnigy, when you change the model type it basically erases everything else you set up. Once I had that little epiphany, I stopped having the problem of losing my settings, and the sim not recognizing my trans. I left the model type on airplane. Installing the directx 9 driver was also essential.

I was then able to go to the next step you suggested: "After that all transmitter settings are done in Phoenix, like servo reversing for controls that work backwards."

It took a little while to figure out, just because I really don't know what's supposed to do what. I unmapped everything that was helicopter and through some trial and error manually set the channels to get stuff to work. I still can't get my landing gear switch to work, and for some reason my throttle stick is activating both channels 3 and 6. Also not a big deal at the moment, since I'm not utilizing channel 6 for anything.

All that being said, I am now flying a plane in a sim!

Thank you for your input, d8veh. Couldn't have done it without you.

Getting the FT models in was a whole other challenge. I'm going to start a new thread for that one.
 

bracesport

Well-known member
#11
I'm on a mac with RC7, I haven't even use a TX yet - still using my right index finger on the trackpad and two keys with my left hand for speed and flaps - I love it!

Gives me so much confidence I think I can fly!

Screen Shot 2018-12-07 at 8.57.31 AM.png