• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

DJI Naza v2 issue on 1200mm octo

#1
hey folks, new to the forum but not new the multirotor world, ive been designing and building large scale UAV's for almost 2 years now.
Im currently having issues with a new Naza v2 on my 1200mm Octo named Frank.
The octo is a modified Tarot ironman frame and the specs are as follows:

1200mm CF frame
1760 Props
300kv Gartt motors
40a OPTO ESCs
2x parallel 6s 3300mah lipo
DJI Naza V2

the problem i am having is it wont stable take off, it violently flips. with KK 2.1.5 and APM it flies fine, tried to use the DJI system and it started doing this. motor and rotor rotations are correct, the DJI program says the GPS is getting magnetic interferance, i moved the batterys and tried to put the GPS further from the electronics and nothing changed, i also tried to run a calibration on the unit with a magnet, still same issue, im wondering if anyone else has dealt with this issue before or if its just a bad GPS unit.
 

Attachments

Merv

Well-known member
#2
I have on occasion had magnetic interference from some metal in the ground. Something like rebar, culverts or under ground power lines will mess up my DJI. If I try to initialize right on top of something.
 
#3
Merv, thanks. I actually made a realization yesterday when the same thing happened with another DJI unit that i fly all the time. I think my house might have both the underground wires and we live near a wire run. I might give it a shot out in the open if I get the chance and see if thats the issue. Thanks
 
#5
I was trying to fly my Inspire 1 in a hangar the other day. Nothing but compass and GPS errors from the metal and power lines in the building. I got it in the air at one point and it was not happy. Same machine outside flys like a dream. As they say: location, location, location.