• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

DJI NAZA V2 problems

blmk

New member
#1
hello all,

I am building a new quadcopter with the naza v2 system, dji 920kv motors, simonk 30a esc's, a standart pdb and a 3s lipo, my transmitter is a flysky fs-i6.
I have built multiple drones in the past 4 with miniquad parts and one big hexacopter with a naza m lite.(so i can say im a bit experienced)

So it goes like this. i turn on the tx and after that the quad. the setup leds go nicely and it goes into gps mode . i can change the modes from my tx i can calibrate the compass. but when i go to arm the quad the arming posicions dont work i have to give full throtle and mmet the sitck at the top ( basiccly the throttle gimbal is on up left and the other gimbal is at top right) after doing that it arms and starts to spin and the motors work BUT the throttle is backwards.

btw while acting like this, on the naza v2 asisstant software when i push the throttle up it slides to the left ( i did all the calibrations and setting chanels by wacthing the tuturial video)

i have tried. reversing the channel on the tx and it doesnt do anything when i reverse it i cant even start the motors
ı have tried reversing from the naza asisstant software and it doesnt work aswell
but when i reverse both of them it works BUT in the same way (the throttle is upside down :( )

so is there any way that i cant reverse the throttle chanel other than these options? or is there a solution?
i havent tried an other tx.

thanks for your help.
 
#2
I don’t know the flysky transmitters but when I switched from a traditional receiver to a S-bus (both hitec optimas) I had to change the channel programming between the modes. Make sure you have the correct receiver type setup in th naza assistant. Good luck.
 

PsyBorg

Fly Angry
Mentor
#4
Seems to me when you say throttle moves the aileron axis that you have channel orders mismatched.

I believe your radio is thinking AETR but the Naza is looking for TAER.