Help! EMAX 20A ESC caught fire


New member
So as the title says the ESCs on my quadcopter caught on fire. I had tested my flight controller, receiver and transmitter which all worked well from what i could tell, so i decided to connect my motors and battery to do a motor test (I'm using baseflight). the first motor worked fine, but the second one had trouble starting and then the ESC caught on fire. I did not flash my ESCs (didn't know if i had too or how), but i did flash my flight controller, a naze32 rev6. The ESCs said on the package that they already had BLheli firmware 2-4s. I dont know if my battery, a LiPo 4s, was charged or not. This is my first time building a quadcopter or any RC device.


Legendary member
i'm gonna guess the power wires got crossed going into the esc or you put way to much juice into it. make sure that esc is rated for 4S. i would be surprised if it wasn't but who knows.


me :cool:


Wake up! Time to fly!
Since you said the motor had trouble starting to move I'm going to say it was either a bad connection like poor solder joints that are common in mass produced bullet connectors or that you have a motor screw shorting one or more of the windings in the motor. Usually fires happen when there is a direct short somewhere and one of the components lets out the magic smoke but creates a path for current to flow and everything gets super charged and hot very quickly.


Wake up! Time to fly!
@Bricks Usually if an esc goes so does the motor as most times the motor is the cause. Haven't seen many people saying they fried a FC from back fed current but I suppose it is possible on an AIO fc / esc combo.