• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

favourite SkyIII 20A esc

#1
Anyone have the directions that come with the Favourite SkyIII 20a ESC from Lazertoyz? I think I need to adust the timing but without the directions to the programming sequence I cannot. I've emailed Lazertoyz but they haven't had time to reply to my email. I assume they are swamped with orders with the changeing of the season.
 
#4
@Xuzme. Yes that is the esc I have. @jaxx, I would love to have one but I'm new to the hobby and this is my first esc so and I didn't think I needed one this quick. Plus is have to order one from lazertoyz and pay 5$ of shipping for a 7$ item.
 

xuzme720

Dedicated foam bender
Mentor
#5
@Xuzme. Yes that is the esc I have. @jaxx, I would love to have one but I'm new to the hobby and this is my first esc so and I didn't think I needed one this quick. Plus is have to order one from lazertoyz and pay 5$ of shipping for a 7$ item.
Did it not come with any directions at all? The sequence is on the bottom of that page I linked to, but let me see it I can find a video on programming the ESC since it will be faster than trying to explain.
 

xuzme720

Dedicated foam bender
Mentor
#6
See if this sequence works for programming yours. Obviously use the chart I gave you in the link above for your features but the technique should be the same or close. If it doesn't work, try half throttle instead of all the way to the bottom...
 

Jaxx

Posted a thousand or more times
#9
@jaxx, I would love to have one but I'm new to the hobby and this is my first esc so and I didn't think I needed one this quick. Plus is have to order one from lazertoyz and pay 5$ of shipping for a 7$ item.
Patnaude_av8r,
I bought mine when I was new to the hobby, because it was much easier to program the ESC (didnt have to use the TX and listen for beeps), and check the currently selected programming options using this card. It's also much faster. The other great thing is that it works on many different ESC brands, so you don't have to have a manual for every ESC you own. Here are 2 I found for a decent price on Ebay:
http://www.ebay.com/itm/Free-ship-H...pt=Radio_Control_Vehicles&hash=item2a23e256e0
http://www.ebay.com/itm/US-Seller-H...Control_Parts_Accessories&hash=item23207472b2
 
Last edited:
#10
Ok, sorry took so long but got a sick kid so had to deal with that.
I entered the programming manually on my esc using the TX and throttle. I followed the directions I found online at the link xuzme sent me. it lists my particular ESC has 8 different options, brake, batt type, cutoff mode, cutoff threshold, motor timing, startup acc, motor rotation, default setting. so there should be 8 different options to adjust, but mine only beeps four times. (beep...beep beep....beep beep beep....beep beep beep beep....then repeats) Clearly not the same programming options than on the website and on the directions without having the correct and accurate program options I cannot program this esc. Correct?
 

xuzme720

Dedicated foam bender
Mentor
#11
It might need you to set all the options in order. As in, first set the brake setting by pulling the throttle to half on one beep to set "no brake". It should then move on to battery type and so on.

That programming card is looking better, isn't it? :D
 
Last edited:
#13
Ok, did a little playing around and this is what I've found.

When I enter programming mode using the TX

parameter....................option 1...option 2.........option 3

beep.............................beep.....beep beep
beep beep.....................beep.....beep beep
beep beep beep..............beep.....beep beep
beep beep beep beep......beep.....beep beep.....beep beep beep


i've messed around going back and forth with the options and I cannot figure out what they mean.
parameter 4 with three options might me timing but I selected each option and nothing different happened.
Parameter 1 with two options worked, I selected option 2 and my power surge at max throttle went away, now I have a smooth running motor at all throttle settings. Weird, what do you think I changed?
I also messed around with the other settings thinking one might be brake on and off, and nothing, I'm baffled, but I think I stumbled on the right option settings

parameter 1 option 2 fixed my throttle problem
parameter 2 option 2
parameter 3 didn't mess with it
parameter 4 option 2
thoughts? on my mystery settings?
 
Last edited: