• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved Gremlin Firmware Update Gone South

#1
Hello!

I recently decided that it was time to break out the gremlin again. I threw it on betaflight and updated the F3 Femto board to 3.5.0 Firmware and updated the ESCs to 10.7 Firmware. All seemed well, however when I fired up betaflight after the updates to verify motor direction and that the gyro/accelerometer were working, I noticed two very odd things:

1. All my motors were in the wrong place. Example, Spinning up motor 1 would actually spin up motor 3, 2 would spin up 4 and so on and so forth for all 4 motors.
2. the accelerometer, though facing the correct direction based on the diagram of the drone, was not following my movements properly. IE: Tilting forward would cause the diagram to pitch sideways to the right. Yaw however was correct, my left was my left and my right was my right.

I did not move the direction of the board in relation to the drone, it just seems like everything is rotated 90 degrees counter clockwise.

Any ideas as to what may be the fix to this?

Thanks for the help in advance!

-Z-
 
#3
I actually was able to sort out the issue. Turns out, for whatever reason (even though my board was placed correctly and motors wired correctly) when I flashed the board it reset everything. I originally had this built by FT when they first came out and so I did not realize the rotated the motors around in CLI and had to adjust the Gyro and accelerometer positioning in reference to the front of the quad. Once I figure that out and entered a few CLI commands the Gremmy is back in the air and flying better than ever.
 

PsyBorg

Wake up! Time to fly!
#4
Way to troubleshoot and fix the issue mate. Thanks for posting the solution too. Maybe tag the thread solved so others may find it easier.