Gremlin v2 RX issues


Active member
Hi Everyone,

We have been assembling the Guardian Gremlin v2 and are now stuck. The build instructions were clear, and RX connection well specified for the SBUS interface. We have connected a FrSKY Archer M+, which seems to work and successfully binds to our TX. In the FC configuration step (betaflight configurator), we are able to connect to the FC and adjust settings. For some reason, the FC registers no stick movements from the RX. I've tried selecting different UARTs, and enabled serial RX on UART2 as specified in the instructions. I've also tried inverting the serial signal in betaflight with no success. Here is the wiring diagram from the build video / flight test store.


Here is the kit we are using:
Flight board:

I'm considering connecting the RX to the FC via F.PORT, as this FC can understand that protocol. Before unsolding/soldering a tiny wire, does anyone have further suggestions on how to get the FC to accept stick controls?



Active member
Flashed the firmware out of desperation, and now it works. I have no idea why, but the configuration was pretty simple from that point on. The gremlin v2 kit is a great idea and reasonable bargain, but the documentation on programming /setup of FC could use a lot of work.