• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

2.5v not enough :/

#1
Super quick question that I couldn't find online.
Just bought this 4 in 1 esc, it works pretty well so far, got it all setup with my fc (flip32) but as soon as I unplug it from my pc, no response? My wiring all checks out, and when I measure the voltages I'm only getting around 2.5v from all the 5v pins(on the 4 in 1)? I tried it with different voltage batteries and still the same result. Is this common or is there any easy fix for this? Thanks for the help!

my esc: https://www.aliexpress.com/item/BS4...re-Dshot-4x30A-Omnibus-F3-F4/32813809273.html
 

ElectriSean

Eternal Student
Mentor
#2
Try to measure the voltage where the connector socket mates to the board. If it's still low there, your regulator is probably defective. If it's at 5V there, the problem is in the connector or cable.
 
#4
Measuring at the joint between the socket and the board yields the same result.

Really? I didn't even know that was a thing? However, I didn't connect connect the battery backwards as with an xt60 it's pretty impossible.

I'm also noticing theres a bunch of 3v pads on the bottom of the esc? Maybe I could use those with a 5v stepup regulator? Or would it be better to use the battery voltage with a 5v step down?
 

ElectriSean

Eternal Student
Mentor
#5
The 3.3V regulators on these are pretty small, they're there primarily to run the STM32 chip, and they sometimes struggle to run just a spektrum satellite rx. You would be better off stepping down your battery voltage.