• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Ar500 rx

FastCrash45

Well-known member
#1
Took my mini scout out for a second flight, it made my slight right turn then wouldn't turn back, power stayed at the same setting and it dove onto the ground. Lights for power on the dx5e tx were flashing, I powered off then on and lights went back to proper power levels and activity and there were no lights on the receiver. Receiver will not bind or take signals from tx and still no light on the rx. The speed control works fine, tested on another motor. Motor works fine too. I've heard there have been problems with this receiver giving up. Is this what just happened to me? Did my old AR500 just give out?
 

SquirrelTail

Well-known member
#2
Had a lockout with my new four star 20. I started to climb after a low pass then the plane all of a sudden went to full throttle, rolled to the left and dove. I don't think I should ever trust orangeRX in anything. Destroyed the cowl and broke the wing etc. 20190311_161949.jpg 20190311_162315.jpg
 

FastCrash45

Well-known member
#3
Had a lockout with my new four star 20. I started to climb after a low pass then the plane all of a sudden went to full throttle, rolled to the left and dove. I don't think I should ever trust orangeRX in anything. Destroyed the cowl and broke the wing etc. View attachment 126220 View attachment 126221
This is the original spektrum ar500. It won't connect at all. Just tried to run servos off a rx pack and it won't bind or anything else. No light comes on either. Luckily it didn't damage the mini scout. Hit some soft snow.