• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

AR8010t and Dx8e wont connect to pixhawk in mission planner

#1
Pixhawk Spektrum ar8010t not binding in mission planner to Dx8e
Hi my name is adam and im a sophmore at central state university in Xenia, Ohio. I recently got into a personal hobby of making drones do things. I had a Parrot AR drone working fine with a raspberry pi but I wanted to make my own due to being able to add anything to one. I have posted a picture of what is going on with my drone in mission planner and the wiring of the drone. I have tried to wire the dsmx reciever to the pixhawk but I only get gray bars and no green. when i connect to the Ar8010t traditional receiver it gives me what shows in the picture. I am a newb and by no means a seasoned pro, I am just the first one at my university to want to get into drones and none of the teachers have a clue how to help me. I have programmed mission planner in python too using stml so it is just getting the hardware to work.https://drive.google.com/open?id=1wZES6pKk8EIMkwK3K1-QdNunNNioqdIx
https://drive.google.com/open?id=1wZES6pKk8EIMkwK3K1-QdNunNNioqdIx
https://drive.google.com/open?id=1bEBL-64ghWbyA3O-beEN_fO9dIYcPdI6
https://drive.google.com/open?id=1g__y_DynqI87qhC73hKCNpf5wBDXEuOx
 

evranch

Active member
#2
The obvious question first is whether the RX is actually bound to your transmitter. All your servo inputs are centered, so you have power to the RX and you are getting a PWM output from it. If it's not giving you anything but centered outputs, that's probably a failure of your radio system. Have you tried to hook a couple spare servos up directly to the RX to see if they will work?

Sorry, I can't really help with DSMX as I use S.Bus on mine. You are trying to use a Spektrum remote receiver for this? All I know is that it has to be plugged into the SPKT/DSM port, not RC IN, and is bound using that servo setup screen.

FWIW I've always found Mission Planner to kind of be a pile of hot garbage, though a few of its functions have still not been replicated elsewhere. I like QGroundControl a lot more for setup and parameter editing, it has a better interface and is much more stable.
 

Headbang

Well-known member
#3
That rx has a few quirks. The biggest one being you must have a satellite rx connected to it or you can not bind it to anything.