• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Arming/Motor and RSSI Issues

FDS

Well-known member
#1
I have been setting up my quad, its just a cheap QAV 250 frame, spec is-
  • Matek F405 CTR AOI FC
  • Chaos 30A esc- Dshot
  • Racerstar BR2305s motors
  • FrSKY XM+ receiver
  • Foxeer predator V3 camera, not fitted
  • VTX- not connected at present.
  • Taranis 9XD+ on 2:1 firmware. Added optional sound files, all switches etc set up fine.
What works
  • Modes switches, I have auto level, acro trainer and acro all on a 3 position switch, it works great.
  • It arms and disarms fine and the failsafe is set to no pulses on the trans, stage 1 and 2 failsafe are working.
  • It flies, auto level is controlled, I flew 4 batteries today without killing it or anything else. Its smooth
  • I can fly it in acro trainer. Has plenty of punch too.
  • In Betaflight all my channels set up to be 1000-2000 exactly.
  • Channel 12 seems to send RSSI, Betaflight can see it.
  • Channels set on Taranis as 1-16 not 1-8
  • I know the XM+ isn't a full telemetry RX.
My problems are-
  • The Taranis does not detect any telemetry. My FC should be sending at least some and RSSI is set to Aux 12, it shows in Betaflight as an active channel but the 9XD won't detect any sensors
  • Even after flying today, the motors still run slowly when it arms. It does this on the bench props off and in the field, props on. Not hard enough to lift.
  • Min Check is set at 1020
  • Min Throttle is set at 1000
What I have done so far-
  • Watched a lot of Mr Bardwell
  • Drunk tea
  • Ignored the low spinning motors in the hope that when flying it will go away.
What I want is-
  • RSSI to work. Some other bits of telemetry will be done on my OSD but RSSI would be useful, since I want to know if my range is good by voice warning.
  • The motors to stay off when I arm. I always disarm and immediately unplug but right now if for some reason I lose signal my motors may remain running in some circumstances, despite the failsafe? I don't want them to run at all until I lift the throttle.
  • I realise I might be having to update the TX firmware. I am not sure about this part. If I have to I will but would prefer not to
I have a computer (Mac) that can connect via Betaflight, I don't have access to it again after Sunday and want to fix these problems before I lose access to Betaflight. I have no other computer or any money to buy one. Everything spare for the next 3 months went into my quad and FPV kit.
 

CarolineTyler

Well-known member
#2
In configuration tab to stop the motors spinning when arming there's a switch which is on by default for quads, set it to off. (Right side, near top)
Can't help with OpenTX much, in deviation on my T8SG V2 I can go into transmitter option and do a discover telemetry
 

FDS

Well-known member
#5
Thanks @CarolineTyler I will click that tab and see whether it fixes it.
I thought that as it transmitted RSSI on 12 you could just configure the TX to read that info. I will search for an open TX guru to get that fixed.
Hopefully you just fixed my quad issue.
 

CarolineTyler

Well-known member
#6
Thanks @CarolineTyler I will click that tab and see whether it fixes it.
I thought that as it transmitted RSSI on 12 you could just configure the TX to read that info. I will search for an open TX guru to get that fixed.
Hopefully you just fixed my quad issue.
It doesn't transmit the RSSI as such, it just presents the RSSI on the channel to the FC which then displays it on the OSD. It never gets back to the transmitter. A price you pay for such a tiny receiver.
 

FDS

Well-known member
#7
Switching that tab made no difference ☹️.
However the motor idle value that was below that tab, when set to zero, did reduce the rate they span at, one has stopped altogether. Going to fly it again and see what happens, then try again.
At least I will see everything in my OSD. I have another RX that does telemetry but it has the non LBT firmware, so need to fix that.
Thanks for the help.
 

FDS

Well-known member
#8
Flew it, the throttle value under the no motors tab is related to air mode, as it had no throttle on when you went down.