• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

DJI Programming Prob CFG-ERR[8]

#1
So I put together a Quad from DJI Innovations - along with the NAZA controller.
Nice machine.
Hooked up the GPS and all that.

Decided to move over to their hex model (F550), so I gutted the 450 of the electronics and started in on the new baby.

On the flight test I noticed the GPS wasn't working. I was getting Attitude hold only. No auto fly home and land and all that cool stuff.

Plugged it back in to the computer and noticed the Naza assistant software was reporting a CFG-ERR[8] problem.
Ok. That's new.
I thought maybe the GPS antenna was iffy - so I borrowed a new one.
Nope same problem.
Tried a new NAZA controller.
Nope - same problem.
Through hours of testing and retesting things only got worse.
I've tried new NAZA, new GPS, new Rx.... basically everything new.

Now I can't even enter calibration mode on the software - it's acting like the Rx isn't even connected or bound or something.

Has anyone got any experience with these devices? I've searched endlessly online and even sent an email to DJI but to no avail (although honestly perhaps I need to give DJI more time to respond).
It's pretty rotten that DJI doesn't have a support forum online.
 
#2
Had the same problem, son in law finally hit the start and went through the calibration and then hit write. The error code went away. Drove me crazy, all on line says it is a problem with wires put in the receiver backwards, nope, not the problem at all. Tried everything could think of. Son in law came to over and he figured it out.

Added: By the way, unless you use G mail or Y mail your email will not get through DJI's firewall. Can you say PAINFUL! Spent days trying to get DJI's permission to use the investment I had made in there products. Old school and very PAINFUL.
 
Last edited:
#3
Well something worked.
I started from scratch.
I think one of the tricks when resetting the controller is to ensure the USB is unplugged.
Also I think somehow receiver type was changed to D-Bus instead of standard.

Too late to try it all out now - but I'll give the GPS locking a try tomorrow to make sure it works.

Frustrating - especially given the irony that I had the DJI Hex work right off the bat with zero issues - complete with GPS auto home/land once I put in the AR8000.
 
#4
Everything checks out OK. GPS hold, and auto home/land works fine.
Flight time on my 3200 4cell battery is really low compared to the quad - I'm going to start experimenting to see just how big of a battery I can get on this baby.