• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Emax 1804 2480Kv Motor Jitter on new quad build

#1
I am have just completed building my storm quad. When setting up the cc3d with Open Pilot Ground Control software i experience jitter on M3 and M4.

I have checked all of my solder connections and re-soldered and all looks to be OK. The motor wires are very thin which posed a problem in the first instance. All motors were soldered using the same process. Could this problem be caused by the ESC or could it be a faulty motor or is it a soldering connection issue?

All motors do spin up during the first power calculation (full speed). When I go to set the idle for each motor during the Open Pilot Ground control setup M1 and M2 set fine at 1165. The Jitter happens to M3 and M4, I can take the idle up to full and the motors jitters.

Details of Quad.
Storm Type B Frame (250)
Emax 1804 2480Kv motors
Simon ESC 12A
Trunigy i6 TX/RX

Can anyone shed any light onto what may be the cause of the Jitter. Any help would be appreciated.
Regards,
Airwolf_0101
 
#2
I ran into this problem last night and was pulling my hair out. (For me) it ended up being that my ESCs "Start Force" was dropped to like 0.03, once I brought them back up to the default 0.75 the jitter went away.

I would give it full throttle and they would just jitter.

Used this doc to understand
http://www.emaxmodel.com/download/BLHeli英文.pdf

Watched this video so I could do "Monkey see, monkey do"
https://www.youtube.com/watch?v=E6epG5E8gAQ

Please note I'm a TOTAL NOOB! It just sounds like you are dealing with what I was dealing with. Looks like the default value is .75 if you're using the EMAX 12A ESC w/ Simon, but might be a nice place to start. Looking over that doc you might want to change the timing mode to maybe mid-high.

I also changed my control frequency to 22KHz.

worth a shot.
 

Epitaph

Ebil Filleh Pega-Bat ^.^
Mentor
#4
I had that problem recently which I have been addressing on my build thread. I got a couple of new motors and it was doing exactly the same thing, yet if I tried the ESCs out on the 2 working motors everything was fine. It turns out that the mounting screws for the motors were a hair's width too long and were touching into the winds of the motor and shorting the phases through the body of the motor (and the carbon fibre of the frame). I cut the screws and that solved the issue totally. A noob mistake that I totally overlooked.

Remove the prop, and unscrew the screws so they are loose, then see if the jittering continues...