• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Havin' a hard time with kk2 first tests!

Talabo

Junior Member
#1
Hi there fellow RC-flyers!

Short summary, I've got a KK2 board, (It is on tricopter mode for tricopter) with 18 amps esc's, and soo on!
My problem before I can do a real flight is that the motors arn't working so great together as I hoped for.
(Managed to make them all start at the same time finally, but there is some problems with them working together)

1 motor is always noticeable at higher speed than the others, and the 2nd motor is never realy changing/adapting to the tests.

So that means there is no possible way to lift my Tricopter higher than 1 mm abow the ground without flipping it back down.

Anyone experienced something simular?
 

earthsciteach

Moderator
Moderator
#2
Make sure your motors are plugged into the correct location on the KK2. I made the same mistake a couple of days ago. Also, recalibrate the escs for the heck of it.
 

Talabo

Junior Member
#4
Yes, and yes :D

I have self-level on so the gyro does work, and inverted the yaw. But now it seems to lean to much to left when I try to hover it. Only managed to hover for 1-2 sec now!

and struggle with the gyro when self-level is OFF.
 
Last edited:

earthsciteach

Moderator
Moderator
#5
Did you upgrade the firmware to the latest version (1.6)? Auto level doesn't work very well on V 1.2, the firmware that comes on the boards.
 

Talabo

Junior Member
#6
Yeah, I'll update it to 1.6 within one week when I'll visit a friend in my home town. The upcoming results will be posted after the update ;)
 

Android

Junior Member
#8
Hi everyone!

I have just completed the tricopter build (first experience with multicopters), and I also have a problem understanding the KK2 board, so I'll just post my problem here - I hope noone objects.
So the first thing - after completing it I ran receiver tests and set the PI and other settings like I found on youtube. The problem is - after selecting tricopter layout, the KK2 shows that left and rear motor rotates CW, but the right motor - CCW. In David's nice tutorial on tricopter scratch build he says that all three motors are rotating in the same direction. Which way is the right one?

The firmware on the KK2 is stock, I'm getting it reflashed soon.

This far I have only managed to lift the tricopter ~1m off the ground, after that it just started rotating and landed in the nearest bush..
 

earthsciteach

Moderator
Moderator
#9
The motors do not have to rotate as the diagram on the KK2 board shows. I fly mine with all motors turning in the same direction. The board compensates for this.

When you say it started rotating, did it spin like a top with no yaw response? If so, go to the mixer editor, then channel 4, then scroll down to Rudder. Change this value from 100 to -100 and see if that fixes the problem. It has something to do with digital vs analog servos.

This video gives a good walk through of the settings for a tricopter. Jump to 33:00:
 

Johan

Senior Member
#10
Hi Android!,

Both can work (David has proven that alright), but:

If all three rotors turn the same direction, your tri wants to counteract that by turning in the opposite direction.
With quads, you have the option of 2 CW and 2 CCW rotors so it has no tendency to rotate by itself.

With a tricopter you can minimize this tendency (but not rule it out) by having 2 CW and 1 CCW.
It will still have the tendency to turn, but less than with all three in the same direction.

You can counteract this by trimming your rudder.

If like David you have all three rotating in the same direction, you can mount the rear motor on the tilt mechanism so that with "no rudder" (servo in centre position) the rotor is tilted a few degrees. In that way the neutral position of your rudder already counteracts the tendency to rotate.

EDIT: just saw earthsciteach's reply (were typing at the same time), try that first (it is less work then mechanically re-attaching the servo).
If that does it, your KK2 was compensating in the wrong direction (the 100 / -100 thing :) ), making it worse.
 
Last edited:

Android

Junior Member
#11
Thanks guys, the video is awesome, learned some new things from it. As now it's late, I'll try the copter tomorrow. I hope I'll be able to hover the copter in auto level mode, then I'll be happy with it.
One more question - is it crucial to upgrade to 1.6v firmware, or the stock one is ok?
Also with the ESCs - I'm using 30A plush - how important it is to reflash them with SimonK software?
 

vk2dxn

Senior Member
#13
@ Talabo
First place your tri on flat surface, go into calibrate sensors and re calibrate.
After you have done that remove M1 plug from kk2.
Turn on tx and set throt to wot.
Plug in battery to tri.
Push and hold No1 & No4 buttons on kk2 whilst plugging in M1 plug.
You will here beep from esc. Then after you here beep from esc move throt on tx down to off- you will here another beep from esc's to indicate that throt end points have been set.
Release No1 & No4 button on kk2.

Then your done, give that a go and see if that fixes your problem :)