• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Help motors refuse to spin

#1
So i am building my first quadcopter, i have tried out everything the motor works if i connect my FC to computer and change the slider in motors tab in cleanflight. when ever i up the throttle the FC blinks green when i set it back to zero the green light turns off. how evernon of the motors respond to the transmitter.
i dont know what information to give but i made two videos to show you the problem.
 
#3
Did you set up an arming switch in the modes tab?
is it necessary? i did mess with the arm switch in the modes tab but nothing happened so i didn't bother and changed it back (removed it) .However i noticed this, every time i turn up the throttle when it enters the arm range it triggers the throttle status flag watch the video you might understand what i am trying to say.
 

ElectriSean

Eternal Student
Mentor
#4
In order for the motors to spin outside the motors tab, the FC has to be armed. If you don't set up an arming mode, you have to use stick arming, which is not a good idea. The FC won't arm unless certain conditions are met. That is what the status command is tells you, which conditions are not being met.

 
#5
how do i stick arm i read online that i have to hold my throttle low and yaw fully to the right to tell the quad to arm. however this doesn't work i even set an arming mode but it seems to be ineffective as it does not work. i am a total noob so forgive me if i am missing something obvious.I saw the video followed all the steps he mentions. still it doesn't work
 

FDS

Well-known member
#6
You need to set a separate switch, your radio should allow you to use channels 5 + 6 for this. More modern quads also use sticks to control Smart Audio, so you will need them for that if your FC and VTX support it.
Stop what you are doing and go slowly back over the whole configuration process from setting up switches onwards. Bardwell has a great set up video for Betaflight that will work in Cleanflight also.
A proper switch arm is a safety necessity, you need it to protect you and other people and property in the event of a flyaway or failure. You won’t remember stick arming if this happens, set up a switch, do it right and fly safely.
 
#7
thanks i got that problem solved. however now one of my props comes lose as i up the throttle can i use all cw motors for all 4 positions?
 

FDS

Well-known member
#9
Do make sure that all your motors are rotating the right way and as above nylock nuts will stop prop loss.
5FAD0DEE-8F81-4B76-BA99-090BD1A235DB.png
 
#10
i bought some nyloc nuts and fasten them now it seems to fit nicely, the props don't come off now. however when i try to fly instead of hovering it tilts and goes in one direction.
 

FDS

Well-known member
#11
Did you calibrate the accelerometer in betaflight? Have you set up modes on a switch so you can do level, horizon and Acro or acro trainer? Are the motors correctly wired to the ESC as per numbered diagram above?
 
#12
I have calibrated the accelerometer. I tried setting up a mode switch for horizon, however nothing changes it tips forward anyway. I noticed the red light on FC turns solid red when i put the thing in horizon mode. I even checked the prop directions. see for yourselfs
I think i screwed up the props, its confusing from the image posted i set up all the motors to spin that way but what about the props.
[Edit] No i checked it again i am super duper sure i didn't mess up the prop direction or the motor directions.
 
Last edited:
#14
i am starting to think its because of the weight distribution however i am not sure tho, i have checked props they are in the right positions and motors are spinning according to the picture he posted.
[Edit] Or is it my positioning of FC should it be placed at the center of the drone?
 

FDS

Well-known member
#15
The gyro will compensate for weight distribution up to the point the battery is hanging right off the front or back. The reason I mentioned the modes switch is that you can get it into a low hover, then go into acro trainer or acro mode, this removes the self levelling and you can see if it’s the gyro that’s the problem, since acro removes gyro control almost entirely. Acro trainer is the best mode for that test if you are new, since you will have a bank limit then. You need to be sure the switch is set up on both the TX and in Betaflight.
If you have props on wrong it usually results in a death spin. Have you been in the Betaflight receivers tab and checked that the stick controls and quad direction match the 3d virtual quad model visible in Betaflight? Go through Bardwells set up video one bit at a time and check each step again. That will eliminate obvious things.
Where you are testing is not helping either, the quad is still in ground effect there, the props are not getting clean air, go to a good open space and lift at least 3ft off the ground.
 
#16
That frame geometry is commonly know as "dead cat". I had a quick look in cleanflight but could see no preset for the dead cat frame layout, you may need a custom mix, look at this page it may help you. I remember the dead cat layout did strange things going forward at take off, I had the same issue with my "spider hex" geometry layout, it's because there very different to a "H" frame and "+" frame layout.
Sorry I can't help any further it's probably at least 8 years ago when I did mine, back in the good old "MultiWii" days.
 
#17
I bought a new quadcopter frame since i could't get the dead cat frame to work, Now when i go into the receiver tab in cleanflight In the preview window the drone is spinning, as you can see in the video all the roll,yaw,pitch etc is set to 1500. I don't know what is causing this to happen please help me out here
[Edit]I am messing around with the deadband settings i will keep you guys posted.
 
Last edited: