• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

I built a drone But I don't know how to configure it. Help please...

#1
This is my first build. When I connect the battery everything works fine but the motors won't spin when I push the throttle stick. I added a spektrum serial receiver thats connected to my DXe. I really need some help fixing this drone.
Parts I used:

ESC: Racerstar RS20Ax4 20A 4 in 1 Blheli_S Opto ESC 2-4S Support Dshot150 Dshot300

Motors:4X Racerstar Racing Edition 2205 BR2205 2300KV 2-4S Brushless Motor

PDB: Matek Systems PDB-XT60 W/ BEC 5V & 12V 2oz Copper

FC:Readytosky Naze32 Rev6 6DOF

Battery: FLOUREON 4S 14.8V 1300mAh 75C Lipo

Receiver: Spektrum DSMX Quad Race Receiver with Diversity

Video Transmitter: Eachine VTX03 Super Mini 5.8G 72CH 0/25mW/50mw/200mW Switchable FPV Transmitter

Camera: Eachine 1000TVL 1/3 CCD 110 Degree 2.8mm Lens Wide Voltage 5-20V Mini FPV Camera NTSC PAL Switchable
 
Last edited:
#3
I would go into the betaflight configurator and confirm that stick movements on your transmitter actually respond.

TAKE OFF YOUR PROPS,
plug in your drone to the computer
turn on your transmitter
Make sure the receiver on the drone is powered on (or else you may need to plug in a battery)
go to the receiver tab,
move you throttle, roll, pitch, yaw and make sure that the configurator is receiving those commands (showing you throttle is increasing when you increase it on the transmitter.

If that works that means your transmitter and flight controller are connected properly and talking to each other. I would then go to the configuration tab and drop the ESC motor feature down to multishot and reboot.

Also make sure that you have gone into the modes tab and have a switch that arms the drone.

If that doesnt work then you may have selected the wrong receiver mode on the configurator tab. It looks like you need to select spektrum2048.
 
Last edited:
#4
When I plug my drone into mycomputer it doesn't read my drone and i installed all the softwares than I restarted my computer i tried a different micro usb cable. I went into device manager, there was no Ports (COM and LPT) and i pressed show hidden devices. I also tried Zadig but It didn't read my drone either :(
 

JimCR120

Got Lobstah?
Site Moderator
#6
I had 4 cables that I had tried. They were all charge cables. The 5th one was a bonafide sync cable.

Lesson: Be careful about what you assume. Assuming good test equipment will throw troubleshooting on a frustrating wild goose chase. I would recommend the verifying tools you are using are what you need them to be. It's a good habit to get into.

By the way, hello RCsquid. Interesting name. Are you in the Navy? Where in the world do you fly/intend to fly? Are you just getting into the hobby?

Welcome to the forum.
—Jim