• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Jumper t12 with inductrix fpv plus help

#1
So I've been using my new jumper t12 with a new inductrix fpv plus. While I have gotten it to work it's not setup the way I want it to be.

The main issue is when I programmed my switches for the motor arming and the flight mode selection. I did get my flight mode switch to work correctly but the LEDs on the back indicating the flight mode are reversed. Red should be agility mode but its altitude hold mode. Blue which is the middle of the 3 position switch is correct for stabalized flight mode. And then when the light is green it's in agility or acro mode instead of altitude hold mode. This isnt that big if a deal but does seem odd.

The big issue is I can only get the motor arm switch to work with my s2 rotary nob. When I put it on one of the 2 position switches it doesn't work. Any ideas with that?

Thirdly. How far should my range me on this little quad? I see YouTube videos of people flying then really far away with fpv. I'm flying line of site and I'm loosing signal at what seems under 3 to 4 hundred feet.

I attached some shots of a few settings. The only thing o change on the switch is changing it to s2 and it works

Any help would be appreciated, thanks
 

Attachments

Merv

Well-known member
#2
How far should my range me on this little quad? I see YouTube videos of people flying then really far away with fpv. I'm flying line of site and I'm loosing signal at what seems under 3 to 4 hundred feet.
If you have a 25mW Tx, 3-400 feet is about right. Antennas are the key to more range.
 
#3
So I've been using my new jumper t12 with a new inductrix fpv plus. While I have gotten it to work it's not setup the way I want it to be.

The main issue is when I programmed my switches for the motor arming and the flight mode selection. I did get my flight mode switch to work correctly but the LEDs on the back indicating the flight mode are reversed. Red should be agility mode but its altitude hold mode. Blue which is the middle of the 3 position switch is correct for stabalized flight mode. And then when the light is green it's in agility or acro mode instead of altitude hold mode. This isnt that big if a deal but does seem odd.

The big issue is I can only get the motor arm switch to work with my s2 rotary nob. When I put it on one of the 2 position switches it doesn't work. Any ideas with that?

Thirdly. How far should my range me on this little quad? I see YouTube videos of people flying then really far away with fpv. I'm flying line of site and I'm loosing signal at what seems under 3 to 4 hundred feet.

I attached some shots of a few settings. The only thing o change on the switch is changing it to s2 and it works

Any help would be appreciated, thanks
You have solved my problem! Now lets fix yous. All I did was slow the switch down see pic.
 

Attachments

#4
Which problem are you talking about? The lights being backwards? or the arm switch? I got the arm switch to work on a 2 position switch. I had to offset it if I remember correctly.
 
#7
They sent me a new board and it didnt fix it. I think the LED is wired backwards. Ohwell doesnt affect anything and Im moving to a brushless mini quad soon anyways. Already burned through one set of motors.