• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

KISS FC Not arming after update.

#1
Hi all im hoping someone here can help.

I have a KISS FC with 30 Amp KISS ESC's, Scorpion 2205 2350KV Motors, with Matrox PDB etc,

I had a motor stop working after a crash the other day, so i replaced the motor no change, replaced ESC no change, replaced FC with lattest firmware flashed.

Setup FC same as old one, all switches etc working in GUI arm switch arms all good, connect battery and wont arm and motor test not work either.

All motor make startup sound when connect power and Blue light's on, on ESC's.

FC blue light goes on when you arm but motors wont spin. Checked power to ESC's with multimeter all good.

Tried different protocols eg, onshot 45, oneshot125, pwm, no change.

Any ideas would be appreciated. Thanks
 

PsyBorg

Wake up! Time to fly!
#2
Did you change your min throttle setting when you reset for the new motor? Did you maybe bump the throttle trim and push it out of the range the FC looks for and will not let you arm in?
 
#3
Thanks for your reply..

I just checked that and min throttle on TX is set to 1000 and min throttle in gui set to 1070 max 2000 min command 1000 mid command 1500.

With battery connected, not connected to PC. When arm get single beep and blue light on fc goes on but motors not spin, when dissarm get 2 beeps and blue light goes off.

Still motors wont spin up in motor test either...

Last thing i can think of is change the pdb its the only thing i have not tried yet..
 

PsyBorg

Wake up! Time to fly!
#5
Not that I think it will solve your problem but your pitch center is pretty far off. That will cause a drift once you do get in the air. Second I see a pretty larger (for level) X and Y on your Accelerometers. Do a calibration as that might possibly be enough for the quad to say I am not level so I wont arm.

As for beeping you get I don't remember mine beeping when arming or disarming. Only the start up tones. Listen specifically to find which motor or motors are talking to you. That may indicate a bad joint or broken wire on one of the esc's to help you trouble shoot a little closer to the problem.

Two other things that catch my eye now as well. The FS number set to 10 underneith where you select the protocol.. did you intentionally leave it there? Most people set that to 0 to enable air mode. The second thing is the low pass filter. usually you don't use that UNTIL you have issues to smooth things out.
 
Last edited:

PsyBorg

Wake up! Time to fly!
#6
What radio do you have and what switch are you using to arm with specifically? I see you have Arming set to aux three and in the screenie aux 3 is in the mid position for a 3 position switch. I also see Aux 1 sitting low which you have selected for Acro mode. did you by chance mix them up? Or maybe not setting the switch to arm fully into high state?
 
#7
Thanks again for your support.

Checked out your youtube channel, most cool...

Anyways, i checked all that, re-calibrated accellerometer, checked all switches seem to be working fine AUX 1 is a 6 position switch, AUX 2 and 3 are 2 position switches, but all seem to work fine in FC GUI when no battery connected and flick arm it says its armed in GUI but wont when battery connected. Buzzer switch turns buzzer on and off when i switch it.

Im using a 9XR Pro with 3 axis hall effect gimbals with 6 position switch mod.

I forgot about the fail safe fixed thanks, As for filter by default it was on high so i lowered it a bit to see if it made any difference (starting to experiment with settings). This was before i crashed and all this started happening... I just want to fly :(

I did notice the pitch offset and adjusted the limits in the TX to fix. ( have to do this quite often )...

I think ill change the PDB today as ive had similar problems before with my ZMR250 after much testing turned out to be the PDB was a very strange thing to everything would work on the bench motor test and all than when you armed and gave it some stick it would just flip over at full throttle...

Anyways I hope it is just the PDB and i can get back in the air. Will update this afterwards with results.

Its just strange on the old FC only motor 3 was not working since changing the FC non work thou all motors are making there startup sound fine and blue light on 30amp Kiss ESC's are on.
 

PsyBorg

Wake up! Time to fly!
#9
Ok right off the bat I see that you have the pwm wire for motor 3 where it belongs but the ground wire in that pair run to motor 5 and motor number 1's ground to number 3's. I think because they do run separate grounds that will make a difference. Go back and check all your wiring to the FC and make sure that each motor is wired correctly to each pin out set.
 
#10
I went back to KISS Flight Controller Firmware v1.02RC28 and now all works fine except that one motor still not working. The ESC must be dead the 1 i used for testing was a DYS 30Amp ESC maybe it just didnt like having a different type of ESC. The motor i tried was brand new out of the box same with FC and PDB so would have to assume that its the ESC. Should have a replacement by Wednesday. For now at least the other 3 motors are working...
 

PsyBorg

Wake up! Time to fly!
#11
Cool good luck with getting back in the air mate. I am waiting on some parts for mine as well so I can be ready to fly again when the weather allows.