• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved New Build - Motors do nothing

#1
HI guys, I'm new at this - PLZ HELP

I just made my quad yesterday from all new parts
I have configured everything in betaflight, the receiver works with the remote, and when I flip the switch to arm, I hear beeps. But apart from maybe a tiny jerk from the motor, I get no movement.
Also, I tried to check the motors/escs on Blheli config, but it seems like no power is getting to the escs...
Samguk motors
Mamba f405 MK2
Flysky i6 and receiver...
do you guys have any idea what might be happening?
 

"Corpse"

Well-known member
#4
I had the same problem when I was making a gremlin. Whenever I would arm I would hear beeps but like you said no motors would spin. I solved the problem by watching this video.

Betaflight sends "Beep Codes" to tell you what the problem is. If you look on the right hand side of the setup page you'll see the different alerts that are preventing you from arming. Hope you solve the problem and get flying!;)
 
#5
Thanks so much!
Unfortunately, I used betaflight to display warnings on my goggles, and when I toggled the aux1 switch, it said armed, so I don't think that could be the problem.
 

"Corpse"

Well-known member
#6
Thanks so much!
Unfortunately, I used betaflight to display warnings on my goggles, and when I toggled the aux1 switch, it said armed, so I don't think that could be the problem.
I would check your esc's then. Do you have a picture of your quad? That would help a ton.
 

"Corpse"

Well-known member
#8
It's a 4 in 1 built into the FC mamba f405 mk2
The motors are soldered right into the bottom board on the corners
UAV futures $99 build. Nice! Since your quad is arming it's not the flight controller or your control link. It's the ESC/Battery/Motors.

Maybe this might help. Make sure that you are running DSHOT on your esc's and then make sure that your flight controller is using DSHOT for the signal. You change your flight controllers ESC signals on the configuration tab. If doesn't work I don't have anything else. Maybe @FDS and @PsyBorg might be able to help.
 
#15
Hey, update...
I realized, dumbass that I am, the battery was not charged.
I charged it up, but then somehow I broke the voltage regulator. There is no power from the 5v rail.
I tried to power the receiver and camera from the vtx 5+v, but that doesn't work for the escs..
So I am going to buy a new fc.
Thanks everyone!!
 

"Corpse"

Well-known member
#16
Hey, update...
I realized, dumbass that I am, the battery was not charged.
I charged it up, but then somehow I broke the voltage regulator. There is no power from the 5v rail.
I tried to power the receiver and camera from the vtx 5+v, but that doesn't work for the escs..
So I am going to buy a new fc.
Thanks everyone!!
We all make dumb mistakes! Just learn from it and move on! ;)
 

PsyBorg

Wake up! Time to fly!
#17
FYI for later... I just build a 3 inch myself using the Mamaba f405 MKII and matching esc. NEITHER the fc nor the esc came with anything written to it. It was straight up empty. I had to flash both the FC and the esc before anything would happen. Also the esc in the stack I bought had to be flashed thru the BL heli app not the suite as I got that same error when I first connected.
 

ElectriSean

Eternal Student
Mentor
#19
Just to make sure, does the esc require a working voltage regulator to function?
Technically yes, the micro-controller onboard requires much lower voltages than it controls. If you're talking about a BEC whose power is output, then not really, lot's of ESC's don't have those at all.