Quad flips out upon any hard movements


New member
Hi all,

I've searched everywhere for an answer but cant seem to find it, i was hoping someone on here could help me.

So my quad setup is:
SpRacing F3 Acro 6 DOF
Racerstar MS Series 35A ESC BLHeLi_S
Racerstar 2205 2300kv motors
on a martian III frame.

Whenever i do hard maneuvers in any axis the quad either whines and locks up for a second, Or it just goes spazz mode and flips out hard.
I have tried doing different gyro/PID loop rates, turning various PID settings low/high, and messing with the stick rates. As far as i can tell, it calms down a bit when i decrease the rates for my stick movement. But that doesnt really solve the problem because now im just turning very sluggish and flying quality starts to suffer.
Maybe a bad gyro or something?

The strange thing is, that i have a very similar build on a martian II frame with same motors and the same SpRacing F3 FC.... One difference is the ESCs though. On my other quad (the one without the problems) it has makerfire 20A ESCs.

So my best guess is that maybe i have something wrong on my ESC settings? I have tried both oneshots, multishot, and dshot. nothing seems to fix it.

If someone can help me solve this I would REEEEAAAAALLY Appreciate it! THANKS!
Last edited:


Techno Nut
I'd start by making sure you are on the latest release of BLHeli on your ESCs. Make a note of what BLHeli release is on them before and after you update and post that here for information purposes. When you update them, Make sure you reset all parameters to default (ie don't save current settings) and then redo your ESC calibration.



New member
I've never done an esc update, reading up on it now thanks.

i also came across an article speaking of prop stalling? is a 5045 prop too aggressive of an angle? What angle do most people use for 5 inchers?


Flite is good
I had a similar problem with my last 3" build.

make sure you flashed the correct firmware to the board.
Go back to stock pid's and rates.

If the ESC's are truly BLHeli S, then set the esc protocol to dshot600.
don't separate pwn from pid loop.
Start pid loop at 1K (once things get settled, you can bring it up).
maybe keep gyro rate at or under 4k till you start to get it sorted (not sure if that will help).

set the throttle endpoints in your radio.

flash the latest blheli firmware to the esc's.
calibrate esc's in the motors tab of blheli suite.
set the motor direction if needed.

balance props and motors.

Try and fly.

If it is settled, start your tuning. To include increasing pid loop if desired.

I had to do the ESC setup a couple times to get it all to take.


New member
Blackbox it, it will show you what motor/esc is having issues (the one that the FC commands to go full thro is the bad one as its not making the thrust it is asked to do). Look for crappy solder connections on that arm.


No Agenda FPV
I've never done an esc update, reading up on it now thanks.

i also came across an article speaking of prop stalling? is a 5045 prop too aggressive of an angle? What angle do most people use for 5 inchers?

Did you calibrate the ESCs at all? Sounds like your ESCs might not know where they are compared to where they should be. I would attempt a ESC calibration in Betaflight/Cleanflight first. Lots of videos on YT that show how to do it, I think the FT FT210 build even has it in there towards the end.


Wake up! Time to fly!
Just to throw another thing into the mix.... When I first started doing the esc calibrating stuff I ran into an issue where I had put several of my esc's into programming mode during the calibration.. Needless to say I had some wonky issues goin on. IF all the above advice does not help try defaulting each esc one at a time back to factory settings. Then flash to current firmware. Yes I KNOW flashing firmware "Should" be setting its own default mode but mix n match gear tends to have its quirks so it is possible it remembers base settings as a feature so people are not resetting all of the parameters.


New member
Im back! So it was indeed the ESCs being calibrated. I didnt realise that i hadnt calibrated them before. Flys like a beauty now, thanks all :)


New member
Hi, back again....

So when i had calibrated the ESCs on cleanflight, it worked great for a little while then out of nowhere it started up again. One thing i replaced was my FC. Its the same FC (SP Racing f3) i just replaced it because i had accedentally ripped off a IO-1 connector. But i dont think thats relevant.

so when i got my new FC, i did the regular things. Flash firmware, calibrate escs, etc...

But this time im getting the same issues falling out of the sky for reasons unknown, i have tried calibrating the escs SEVERAL times, and cant get into blheli suite. the message i get is "Initialization of flight controller denied! Please check all motors are stopped and disarmed!"

I believe my motors are stopped and disarmed, i hit the stop motors button on cleanflight.
so i cant flash my ESCs, not sure why this is.

The quad seems to always drop out to the front left motor (motor 2?) every time. Ive looked in blackbox and found that the motor maxes out upon falling. I also hear like this long solid beep noise while it falls. Im assuming this is the ESCs desyncing because thats what it was last time, but im fresh out of ideas. any ideas anyone? Thanks!