• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Racerstar 4 in 1 ESC receiver always in bind mode.

#1
I am building a V-tail Hunter Quadcopter I used a Racerstar StarF4S 30A 4 in 1 ESC/Flight Controller upgraded to betaflight 3.2 and an Orange r617xl receiver. I bound the rx to my Devo 7E before the build and it bound fine. But now that the leads are soldered to the flight controller whenever I recycle power the receiver goes into bind mode. It seems to bind (for all of the good it does considering it resets each time I power it on) the light stops the fast flash and goes solid when I select bind on my transmitter. But the flight controller gets no signal. I did NOT use the betafligt CLI to bind the receiver and I ran a dump and verified that these functions are all set to off or 0. Additionally I thought it might be a poor solder job but with the signal and ground pads separated by that 5V+ I don't believe it is simple as the connection. Does anyone have any insight into what might cause this behavior. Could the flight controller be defective oddly when I check the flight controller for continuity between the signal and ground pads I don't get any. I don't know why my rx is going into bind.
 

ElectriSean

Eternal Student
Mentor
#2
Not sure how you have things connected, but note that this is not a Spektrum serial based receiver it is CPPM so it has to be connected to the PPM port on the FC, not a UART, and configured as such in Betaflight.
 
#3
Banggood Schematic

I can attach pictures of the build but this picture from banggood shows the PPM and SBUS both using the same points.
I have re-soldered the connection several times to make sure it is good.

7448e1e3-72db-42d4-8cf9-2bd2c7a8c553.jpg
 
#5
Hey Graknil, did you end up figuring this out? I'm having the same problem and any advice would be much appreciated! Thank you