Real Flight 9; Problems loading software


Well-known member
Hi Everyone,

I received my RF 9 yesterday in the mail. I was excited to receive my package. I knew the weather was going to get bad but I could starting to re-learn how to fly again. Here is where the problems starts. I looked at the installation guide and see there is not much info. I follow the guide with no luck. Tried that about a half dozen times. No real proms come up to follow. Then I thought about going to the RF site and down load the software from their site using the code on the back of the case. No luck again. Computers give me headache. I am hoping that I can find help in the RF site. But has anyone had a tough time loading their software ? Is there any other sites that can help with down loading RF software ? Right now my RF 9 is about 18 hours old. Did I say anything about a headache. :cool:

This is interesting. I was able to install The Phoenix flight sim. I know that my dvd drive works. In a little bit I will uninstall Phoenix.

Well guess what. I tried to install RF 9 and no luck. Headache continues.

Update; I have found this out. " It is important that you plug in your controller into the computer first, before installing the Real Flight software ! " My computer will chime when I plug in the controller but no dialog box shows up. I think I need to install the necessary drivers or appropriate files but I can't seem to find them. Can someone point me in the right direction. Thanks again for any help. The controller is a InterLink DX.

Thanks for any ideas or help,
Last edited:


Elite member
I am having same problem with rf 9.5.
Won't install.???
I don't recall any problems with installing. I have RF 9.5 with the Interlink DX, installed on a laptop running Windows 10.
Do you have an account with Administrator privileges on the system you are installing on?