• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Help! Servo jitters

mayan

Well-known member
#1
Ok so am puzzled I can’t understand why this is happening.



I have already advised over PM to try figure it out and did a bit of checking. So here is what I already tried and what I am still to try.

Hai-Lee said:
Having said that I will ask if you can replicate the issue using a servo tester?

No. I don't seem to be able to replicate the issue using a servo tester.

Hai-Lee said:
If you just swap the aileron servo connection and the rudder servo connection on the Rx does the problem stay with the rudder servo or does in transfer to the aileron servos?

If I connect the servo to the ailerons channel the issue stays with the rudder.

Hai-Lee said:
Does it do the same thing with the motor leads disconnected from the ESC?

Yes the issue stays the same.

Hai-Lee said:
Does it still do the same thing using an alternate ESC? (No need to have motor connected)!

Hard for me to check because the other ESC that has the same banna connecters (3.5mm) is also giving me an issue. It's the one used in the Tedge which has a similar issue with the ailerons. So using a different ESC that also gives an issue won't give me a good indication.

Hai-Lee said:
Has the ESC/Motor ever been crashed?

On the Mini Edge yes on the Tedge no. On the the Tedge the servos, motor and ESC are all new.

Hai-Lee said:
Have you ever got your Tx wet?

Not that I recall but the issue hasn't happened with the TT or SpiTTT. The only difference between these models and the others where the issue occurs, is the 3.5mm banna connectors.

Hai-Lee said:
Does it still do it with a different motor fitted?

Won't make a difference if the problem occurs even without the motor connected.

Still puzzled here so I want to open this up to everybody someone might have another idea or learn from it.

I still need to try to power the Rx using dry cells to eliminate the BEC failure.

Any other ideas why this happens?
 

Arcfyre

Well-known member
#2
Hey buddy. I have this happen to me too when I'm standing too close to the plane. For me it's always the elevator servo though, lol. Usually by giving a small control input it goes away, and I have never (to my knowledge) had it happen in flight. I always just assumed it was a feedback error or something, like what happens when you hold a microphone too close to the speaker it's broadcasting out of.
 

Merv

Well-known member
#4
Are the gears in the servo is worn out, too much slop, backlash. Metal gear servos will wear out much quicker than others.
 

Paracodespoder

Well-known member
#5
I had the same issue with my ft edge, didn’t cause any flight problems. I thought it was just because the control surface was so large, still don’t know what it was.
 
#6
You have what sounds like 60hz buzz which indicates reception of a "Polluting" signal at some odd harmonic. In my experience it usually affects only 1 receiver channel (usually #1) where the servo is hunting to keep up with a signal. Also known as zero beating. It might affect #5 or 6, ive never flown more than 3 channels.
Straight crystal does this when you get too close or have cheap imported fluorescent lights on some frequencies. Separate the radio/transmitter a couple of feet, go outside. I've never had it affect a flight. 72.4 mhz is famous for this due to police/fire bands, 75.5 ditto
 

Wildthing

Well-known member
#7
One of my 3D planes the elevator servo did it, I could sit there and watch it jitter, touch the control surface and it would stop or when I moved the stick. Never affected it in flight at all. I think with the weight of the large surface plus the control rod was mounted on the farthest hole on the servo arm the servo itself had a hard time keeping itself centered. I changed out the servo and even rx and still had the same jitter.
 

mayan

Well-known member
#8
Thanks for all the inputs at least now I know that I am not alone. I also haven’t had issues with this during flight but still launching a plane that way is kind of scary you all must admit.
 
#9
If you're on 2.4ghz this is more likely a bad connection normally on the earth/neutral side of things. A loose aerial or dodgy servo wire connection shows up like this. Are your aerial wires 90' to each other.

If you're on 35mhz it's more likely interference but you really should be on 2.4 these days unless your wanting to do some serious distance work.
 
#13
As long as they have a decent amount of space between them you should be ok but won't be getting max performance if not close to 90'. If they are alongside each other or even worse twisted together like I've seen some people do then your going to have problems.

It's also worth noting that having your transmitter aerial pointing straight up on a 2.4 system lessons range, if you angle it so your aircraft sees the side of it you'll have better reception.
 

Bricks

Well-known member
#14
I have run into this when the BEC could not keep up with the servos, in other words the servos were trying to pull more amps then the BEC could put out. Many times people blame this on the receiver and ultimately leads to a brown out of the receiver so they blame the radio system..
 

Wildthing

Well-known member
#16
It’s a 40A that I am using can it be that the ESC can’t hold up?
Take a close look at your esc, it will tell you how many amps the BEC is rated at. Most esc's are only 2 or 3 amps , 3 or 4 servos you are usually good for but anymore it can't hold up. Then you install an external bec that is rated say for 5 or 6 amps.
 

Hai-Lee

Old and Bold RC PILOT
Mentor
#19
What drives me nuts is that on some planes using the same equipment it just doesn’t happen.
Just a recommendation to possibly help with the resolution of your problem or issue!

You could post all of the things that you have tried to resolve the issue without effect or had a minor effect so that you do not get many suggestions all very similar. Like most problem solving from the other side of the world the more info the better and this should include failed measures as well.

Just a suggestion!

Have fun!
 
#20
Are you using digital or analogue servos? The radio and/or esc could be set for the wrong type.

Edit, have you calibrated your esc?
Have you used extender cables on the servos?
Extender cables should be as far away from esc wires as possible and as a side note, if you've used cheap cables they can be faulty.
When you tried the servo tester was it from the receiver end or directly on the servo plug?

If you want to rule out power issues you can separate the power wires from the servo and put a power source directly to it and just run the signal wire to the receiver. You can carefully pull the connectors from the servo plug and just hold them on a battery pack.
Or pull the signal wire, plug it in your extender wire or receiver depending how its wired and plug a pack on the servo plug that now only has power lines in it.
 
Last edited: