• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Skypower ESC throttle range issue

#1
I am just finishing up a FT Alpha build and am having a strange issue with a Skypower ESC. I got several of these when Headsup was going out of business.
My overall setup - Skypower 20A ESC, Jumper R8 RX, Taranis QX7 radio, DLFPV 2205 2300KV motor. I have a throttle cut switch which forces throttle channel to -125, 3S battery)
I powered up the system and as soon as I "enabled" the throttle the motor started spinning (and that is why you test with props off). It was not a matter of needing to reverse the channel as I could ramp it up. I discovered in another thread that the ESC seems to re-calibrate itself on power-up. They suggested to set the switch to -100 (normal low throttle position). I did that and that resolved the issue with motor spinning when enabled. I then started to ramp up the throttle and just below 1/2 throttle the motor started "chattering". (Radio said throttle position was 1300)

I had a Skywalker ESC available from another build that used the Spektrum radio. I connected that all up and everything worked perfectly with both throttle cut connections (-125 and -100). I was able to go full throttle (2000 on radio) and the RPM's were definitely higher than the 1300 on the Skypower ESC.

Anyone have any thoughts on this. I was using the Skypower ESC as it had longer motor leads which worked better in the build.

Thanks
 
#4
@ Merv - I did go through and try changing the timing after I posted this, had no effect.
@FDS - I am not able to find any information on calibrating the ESC in the documentation that came with the ESC.

I also tried a new Skypower 30A ESC and a 30A that was in an FT Explorer. Both of those had the same issue. The Explorer was running off of a Spektrum radio system.

Seems really weird that Hobbywing Sky Walker works fine and the Skypower does not.