Help! TaranisQ X7 uploading wrong bootfolder


New member
Hello All;

I am new with rc. I bought taranisq x7(accst) when I wanted to bind my radio with r81 nano receiver. I tried to flash firmware to my r81 , instead I flashed RM T8(I didnt know it was radiomaster remote controller) files to my Taranis x7. So My screen stuck in the Bootloader and buttons lost their functionality. The thing I can do with buttons just go up and down. So I cannot select files on Bootloader.

What I tried so far:
-Downloaded latest Open TX companion.(Also tried older versions)
-Write latest firmware to my Taranisq x7(which it says "FLASHING DONE")
-On Companion, Edited radio profile to "FrSky Taranis X7 / XS7
1.Create new otx file "Write Models and Settings To Radio" but pops error "Can't extract RADIO/radio.bin and following popup page says "The radio firmware belongs to another product
family, check file and preferences!

(In png file, When there was no issue I used to see "Taranis" but now RM T8.)

Can someone send me taranis eeprom and firmware bin and I gonna copy and paste to this folder? And does it work?

Thanks alot


  • another remote folder.PNG
    another remote folder.PNG
    12.8 KB · Views: 0
  • write models and settings to radio.PNG
    write models and settings to radio.PNG
    77.7 KB · Views: 0


Wake up! Time to fly!
You will probably have to go to github page for Opentx and download the accst version for the Qx7 and then point to where you downloaded that file thr companion and THEN flash that. What it looks like to me is you only have the RM8 files loaded or available to flash. Keep in mind that every version of open tx has its own separate file for the memory card as well so they have to match. Should all be there on github just might take some scrolling back until you find the last version of ACCST.


New member
Well I dowloaded firmware and sd card content for Taranis qx7. I flashed firmware and copied sd card. I can see that sd card folder and firmware were changed to Taranis. But still on usb name there is still "rm t8". I think I have to change EEPROM file right now.
- I can read models and settings form radio which says taranis. And also I can write otx file.
-When I write models and settings to remote controller , it doesnt say "flash done" but when I flash firmware it does.
I think some how I have to change "EEPROM" file.