Two ESCs don't work


New member
Hello friends,

I have a quadcopter kit based on naze32 rev6, EMAX 12A with BLHeli and four motors.
I have build my drone and configure my FC.
When I wanted to test my motors I noticed that two motors (CCW motors) are not going. I tested the motors with another esc and I saw that the ESCs were the problem.
I tried to configure trothle and to reflash BLHeli firmware but nothing. When I plug the motor I hear two beeps from esc but they not work.

What's the problem?
Are ESCs defective?
Thank you in advance and sorry for bad english.

Prodan Pavel


Construire Voler S'écraser Répéter
How did you try and reflash the ESCs? The old Emax 12A ESCs require a programmer to be soldered to the programming pads. Those ESCs cannot be reflashed using the one wire method like newer ESCs.

Can you provide some photos of your solder connections between the ESC signal wires and the Naze? What software are you using to configure the flight controller (cleanflight, betaflight, etc)? Did you test the motors using the motor tab in the software?

Two beeps means that you're getting power to the ESCs.


New member
Escs don't work

Thank you for your advice!
I heve reflashed the ESCs with arduino uno ICSP pins directly to ESC bootloaders pins.

Screen Shot 2018-03-28 at 17.00.48.png

I use the newest version of Cleanflight.
Yes, i have tested my motors using motors tab but only CW motors works.
I think it's either a coincidence that only CW motors works or it's a soft problem.
I bought the kit form Aliexpress and maybe the chinese forgot to flash the firmware.
I have also measured with a multimeter the motors and they're okay.
There is a way to verify if the ESCs are okay?
In the below video the speed of the motors from clenaflight is 1500 Throthle.

Thank you!


New member
Thank you

Hello friend,

I have solved the problem.
Today i have the first flyght.
Thank you for your advices!