• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Ultra budget quad build.


Some guy in the desert
Don't think foam would have helped much in that last crash :D

Decided to just do some flying tonight, so ran to the park as soon as I got home from work. And just barely had time for one pack. But flew it until my TX timer went off which left me with 3.65 in each cell when I stopped flying...but it drifted back up to 3.7 by the time I checked it at home. Battery was at 14%. Just about perfect. Not sure why the TX went before the battery beeper this time. I was flying harder than I have before. The extra D I gave it really gave it the feel I've been looking for and I felt a lot more confident with it. Got it higher, faster and further away than I've done before. Did quite a bit of the pack in Horizon and Acro modes too. Really starting to like Horizon, acro is still a bit too crazy for me and gets out of hand quickly.

May try and swap back to the mega after dinner, maybe I'll work on the cradle...maybe I'll just relax :D


Some guy in the desert
So things have kind of stalled on this project this week :(

I did get my replacement mega board...but decided to wait on the 6050 before swapping back to it. I expected the 6050 here by now (ordered from a close US seller on ebay) but it's still in the clutches of the USPS and doesn't look like it will be here today either. I did start on a better camera mount...but don't have enough ply to finish it and haven't had a chance to get to the store for more or found any other materials laying around that I could use instead.

Next 4 days I'm busy with family stuff and won't be able to do anything even if the 6050 comes in. Heck I probably won't even get to fly :(

But I have been flying at least a pack every day even if it's just hovering in the backyard or small circuits in the front yard. And I'm really loving this little thing.

Not being able to easily tweak my PID's since I don't have BT hooked up right now has let me focus on just flying instead and I can really feel my skills improve.

Hopefully early next week I'll have my 6050 in hand and will work on swapping back to the mega, adding my other 3.3v sensors back in, swapping the wii bits for the 6050 and then once it's flying again finally adding my GPS module.


Some guy in the desert
So the past few days of quad abstinence were due to a forced road trip to LA to see an eye specialist for my daughter. Good news though, she doesn't have the condition my wife does that our local doctor had diagnosed her with. Two different specialists in the disorder checked her out and said she has no signs of it at all!

Downside is between a rental car, two nights in a hotel in LA, parking in LA, food in LA and a day in SD on the way home to decompress...the quad budget has taken a pretty good hit. Don't think I'll be getting my new ESC's before the end of the year.

But we got back this afternoon and my new 6050 was sitting on the counter waiting for me. So my ideas came together. I pulled out the 3.3v sensor harness and added the 6050 to it. Then programmed the new mega board for it and hooked it all up...seems to be working. Though it appears I may be getting reversed numbers for acc which doesn't make much sense as the acc and gyro are in one unit on the 6050 so I'm not sure how one can be backwards and the other isn't. Will have to check things out again the morning. I was able to crank the I2C rate from 100kHz to 400kHz and still have zero I2C errors so that looks good.

Of course then I had to keep going....

My HMC5883 board has both 3.3v and 5v pins...but the part is only a 3.3v part so the 5v pin shouldn't be necessary...disconnected it...and sure enough still get values on everything in the GUI!

So that means no 5v necessary and that means no LLC board should be necessary. So next I bypass the LLC board by connecting the SCL and SDA lines on either side of it together. Yep, still get values on every sensor!

So I remove the LLC completely and the 5v for it. And now I've got nothing. Crud.

The wiring is a mess right now though. From having had the 5v in the loom to removing it the whole thing is just way non-optimal. So tomorrow I'm probably just going to take all the wires off and make a new loom planning for only 3.3v right from the start.

Then I'll try and get the GPS working. Then once this board looks good I'll deal with getting it on the copter.

I have to go to a friends tomorrow evening to help him with a wiring project on one of his dune buggies and he's an old RC Plane guy who's starting to think multis may pull him back into the hobby. So I want to take mine over there and I hate to mess with it just yet since it's working as is right now. I have the whole day off though so maybe I'll get this second board working well enough I feel safe flying it. Or maybe I'll get my wife to come up to the park and get some better video for me since she has the day off too...


Some guy in the desert
I should probably mention at this point that the subject of this thread is probably not that accurate anymore. Rather than just "Ultra Budget Quad Build" it's turned into more of a "Ultra Quad - Budget Build" as my piecemeal upgrades have left me with a goal of having the latest greatest bits possible for the lowest cost. Just buying a premade FC is still the best bet for most people. But to be able to experiment with different sensors - and I really like mounting the sensors separately from the FC itself - the DIY approach is outstanding.

This second controller I'm working on as a replacement prices out as follows:
Adruino Mega 2560 - $16.99 ebay (shipping included)
MPU-6050 gyro/accel - $5.99 ebay (shipping included)
HMC5883L Mag Compass - $2.31 ebay (shipping included)
BMP085 baro - $2.95 (shipping included)
LLC $5.64 ($3.36 was shipping actual part was only $1.95)

So I'm at $33.88 in electronics to make my FC with a full suite of sensors. You can easily leave off the mag and baro to save $5.26 if you don't want head lock and altitude hold and won't be running GPS. You could also use a pro mini instead of a Mega if you want to run a simple accel/gyro only setup and then you're looking at just the $5.99 MPU-6050 and the pro mini, the one I got was $4.98 (half product half shipping). So that could be a usable flight controller for <$11 delivered. If you built more than one of them you could save on the shipping and easily put a few together for <$10.

But obviously I've given up on total budget. And once I have the new board working well(*) I'll be adding:
uBlox NEO-6M GPS - $16.82 ebay (shipping included)

* -I've figured out that the reason the sensors aren't working on mine is I do need the LLC board...totally forgot that the arduino is 5v itself. The MPU-6050 is working by itself (and pro mini's are available in 3.3v versions so you could still do a minimal setup without a LLC) but the other two sensors aren't talking to me. WAY too windy to fly today (20-30 with 40mph gusts...was impressive watching the vertical landings at MCAS dropping off my rental car this morning. Think it was just one of the harriers that have been here forever though and not one of the new F35's they've been flying more and more of lately, didn't sound loud enough.) so I'll probably strip down this new board and do it right. Get all three sensors wired clean with the LLC and then see how it does. If I was doing it over again I'd probably just pay the $17 for a pre-made IMU off ebay. Four wires and you're done. Much simpler than the mess I've made :D

So my total cost on electronics to build a high end fully featured FC is $50.70 for parts delivered to my door including GPS (and full waypoint navigation was just released in beta this week and I'm using one of the two recommended GPS modules so I should be able to experiment with that real soon.)

Ok. Got to do a few things around the house, then warm up the soldering iron and try to stay warm (it's only 40f out here but that's cold in the desert!) doing some better wiring on these sensors this afternoon.


Some guy in the desert
So here's the test rig from last night:


And a closeup of the sensors, I just stuck them on a piece of foamboard with some 3M outdoor foam tape since it held them fairly securely - but came off easily enough I could re-position them as necessary.


At this point I tackled a home project that's been on my list since we bought this house 6 years ago. I finally figured out why the outlet by the dining room table didn't work. As I suspected it was a simple obvious fix. I've just never cared enough about that outlet to take the time to really investigate it. Turned out to be a broken wire right at the terminal on the side of the outlet. Plenty of extra wire in the box to easily repair. Woo Hoo I can work at my dining room table again! This is the dining room table I grew up with as a kid, I learned to solder at this table. Love being able to work at it and have power again! (To be fair there are 4 other outlets in the room - but none of them on a wall that is near the table.)

The table has seen better days and I really need to do some major repairs to it's top...but I'm worried that if I fix it up I won't want to do projects on it anymore ;)

I dug in on stripping everything down and before I had a chance to pick up the camera I had a new wiring harness:

Works with the I2C bus set at 400kHz and no internal pullups. Still not 100% sure my sensors are all pointing the right way - the acc still seems to be reading "backwards". The pitch/roll indicators and artificial horizon work as expected, but the little 3D attitude display and the compass seem kind of crazy.


The markings on the Mag and 6050 match for X/Y/Z...and the mag and the gyro read as expected. But the acc values are inverted from what the FAQ says to expect. But since the acc and gyro are part of the same chip I'm really not sure if I need to change anything or not.


The LLC board makes it quick and easy to use 3.3v parts on a 5v arduino. Just wish shipping and handling didn't cost twice as much as the board itself. Crazy that I can get a baro or compass shipped from China for less than the cheapest shipping option for something even cheaper from a company in my own country.

I also made up a harness for this guy:

No photos of that yet. I'm still debugging. At this point a little lost on even how to debug. I know the GPS works and I think it's configured correctly. But in the GUI I don't seem to be getting GPS values. Just trying to find some lower level GPS logging still...
It is ambitious to take on a project putting together so much of what is already available in an all in one package for a reasonable expense; but I also fully understand the allure of doing such a thing. Keep up the good work on it and have fun with it all!


Some guy in the desert
It is ambitious to take on a project putting together so much of what is already available in an all in one package for a reasonable expense; but I also fully understand the allure of doing such a thing. Keep up the good work on it and have fun with it all!
I prefer to think of it as "Custom" instead of "reinventing the wheel". :D As I've said before I'm not doing anything new or groundbreaking...just putting together pieces that other smarter people have already worked out. But I've got a big thing against "Black box" style electronics and much prefer modular hackable stuff. So this fits my mindset much better than an all in one solution.

When I build another I don't plan on going this route again. I may still stick with an Arduino (unless I decide to go 32bit) but would get a pre-made IMU rather than individual sensors. The really nice thing about the route I took is I was able to evaluate MW for zero out of pocket expense to determine if I liked it as a platform or not. Given how many boards are out there and how many different sensors as a beginner I was overwhelmed with choices and didn't know where to start with picking a board since the KK's were out of stock. So rolling my own let me get a taste and decide that I like the abilities of MW without having to make a choice on which of the many boards to try.

Did some more table testing...checked out some pre-built IMU's and AIO's and confirmed that my mag and accel/gyro are in the correct orientation relative to each other. But still can't figure out why I'm getting inverted values off the accel. Started looking at the MW source last night and the bits that deal with the 6050...but it was late I was tired and didn't get far.

Then things started going totally crazy. Turned out the 3.3v wire to my compass broke, so I've got to fix that today.

The 6050 gives way different readings than my WMP/NK combo did so as expected my PID's will probably change a lot. It reacts so fast though that it's hard for me to follow the numbers and tell if the values are going up or down - good thing for graphs! Can't wait to try this in the air...just want to be sure that the acc appearing reversed isn't going to be an issue...


Some guy in the desert
Photo not very good on tonights progress (my nice lamp is in the other room with my soldering iron now that the back table is available...but there's no computer in that room) but progress it is:


GPS is working! Turned out the problem was I had the GPS module set to 38400 baud instead of 57600 baud for some reason. Not sure how I managed that...this GPS config software is pretty crazy and I can't quite get my head around it. So instead of resetting the GPS to 57600 I just set MW to 38400 for the GPS since it seems it sends it's own init over anyway so the baud rate is just used to send the initial speed setting from what I can tell.

In the GUI I get full GPS data now. I can't figure out the maps in the windows GUI yet...but hey it's still beta so it's probably only half my fault I can't figure it out and I haven't put much time into it yet.

I'm dying to get this new board in my quad and try it out because the acc/gyro seem so much more responsive and sensitive...but something is still wrong with the acc readings. I finally figured out that they aren't inverted like I thought at first...they're on the wrong channel. It's like my roll and pitch are reversed. And the Yaw on the gyro is backwards. Now if I was using individual sensors I would assume this would be because I mounted them wrong or have some settings wrong...but with the 6050 the gyro and acc are in the same physical chip so it can't be that they're mounted wrong. And I have a hard time believing that I'd have to manually swap the roll/pitch on the acc and invert the yaw on the gyro since I have I have the defaults for the MPU-6050 enabled. So I keep thinking there must be something else I'm missing. If I can't figure it out and don't get a reply to my post on the MW forum then I'll just start fiddling the overrides to try and correct for it and see how that goes.

I'm so tempted to just try flying it since the roll/pitch/artificial horizon indicators all seem to work....but those values being off really makes me suspect it won't fly right. Thankfully it's still really windy so I haven't been tempted to "just fly it" but weather is supposed to be getting a lot nicer the next few days so I'm itching to have it working!

Hope the Android config app gets waypoint support soon...I know the maintainer is working on it. I don't have any windows laptops and the mission planner is only functional in the windows GUI right now and coming soon to the android app.

Oh Also in that photo is a modified RX I'm playing with:

This was one I crashed and broke the antenna on...I resoldered the antenna but don't trust it to have full range anymore so it's kind of a play RX now. I decided to try and make things as minimal and clean as possible by removing the connectors and just adding a pigtail for the channel lines. Definitely cleaner wiring...but not sure I really like it. And I still don't trust this RX to have full range. But for now it's ok for testing.

Time for bed now...and dreams of autonomous flight soon now that I have GPS working!


Some guy in the desert
Well, that was a fun way to spend an evening.

After not hearing anything on the MultiWii Forum about my mysterious readings I started messing around with the FORCE_ACC_ORIENTATION, FORCE_GYRO_ORIENTATION, FORCE_MAG_ORIENTATION lines in the config file to try and get things reading correctly.

But after fiddling around a bit I was only getting myself turned upside down and inside out trying to keep that many axes straight in my head.

So I looked in the def.h file which I had noticed contains a lot of defines for stock configs. Basically when you say something like "I have a FreeIMUv043 board" the def.h file has code that expands out with all the details for that board. Oddly enough looking at the various defines in there I saw that different boards using the MPU-6050 were using different ACC_ORIENTATION and MAG_ORIENTATION lines. Though upon closer inspection it just appears that some boards mount the chip facing one way while others mount it a different way. Relatively the directions all stay the same between the various setups. So I grabbed one of those as a starting point and boom my ACC/GYRO were responding correctly in no time. Then I grabbed a MAG_ORIENTATION line from a board I thought had it positioned the same as I do...but it still took a few iterations to get the MAG responding correctly as well.

But wow. What a difference now. The Compass arrow really does point at N now. And I can see a major difference in how quickly the gyro and acc react. This has got to feel substantially better in the air and I can't wait to try it out. Probably won't get it in the airframe yet tonight though. Partly because I still want to fly it on the promini one more time, but mostly because it's late and I still have to cook and eat dinner when my wife gets home. So I probably won't get to swap electronics around tonight.


Some guy in the desert
It's alive again! No video yet, too dark out. I only did a few small take-offs and hovers. Bone stock MW PID settings which before were pretty much unflyable now worked great. It's way more stable in the air with level mode, but I'm more out of control in acro than before (since it has less expo and scaling stock that's not surprising.)

I do have a small problem with my bluetooth, but I think it's actually a phone issue more than a MW issue. It worked, just intermittently. It could be a broken wire in the BT harness though.


There you go! That was actually taken just after the first test flights. Can't wait to have a nice calm day and room to really test the GPS out.


The new sensor board is attached with a sandwich of 3M foam tape, 1/8" craft foam, 3M foam tape. Front of the airframe is actually down in this photo.

I made sure to get some photos of attaching the arduino this time:


On the right is how the zip ties I use come. On the left is one I've cut.


I had to bend the one zip tie to get it to hold the board a bit better.


This actually makes for a very sturdy mount. Plugging and unplugging the USB cord from the board it feels like it's mounted with bolts. The foam should give some vibration protection, not that there are any sensors on the arduino...but if you were trying this technique with a pre-built all in one board I'd probably use thicker foam.


Lower left corner of this photo is why I like the mega board. From the bottom the first harness is I2C, the next is the GPS serial and then the bluetooth serial. Above that are the four motor connections.


This side is power on the left, and then RX connection on the right. Still need to clean up a lot of wiring, and a lot of wires are still WAY too long.

But it's flies again and it files great! Can't wait to try it in the light tomorrow.


Some guy in the desert
Wow. The 6050 was totally worth $6 :D

[Big understatement up there^^^]

Got to fly a pack through it this morning - still just in the backyard though. Didn't try acro mode yet, but angle and horizon are night and day better. Just feels so much more locked in and stable. But at the same time more responsive and quicker. Amazing what a difference a few years in tech on gyros/accels makes!

Still on stock PID's, expo and rate. I definitely have a bad signal wire on the bluetooth. If I hold the wires in place it works, but if I let got I get dropped packets left and right. Need to solder new ends on those and then take it up to the park for some tuning.

Oh the magnetic head lock feels totally different now too. Much more noticeable when it corrects.

Only lingering complaint is the response on the ESC's still feels slow. And I've already suspected that that's due to the stock multistar firmware. Really tempted to bust out the fine tip for the iron and try flashing these.....but don't want to fry any either since I don't have spares. Few more weeks, then I should be able to order some new ESC's and get simonk on them.

Can't wait to try this at the park and get the PID's dialed in. Flying better now on stock settings with beat up props than it did on tuned settings with new freshly balanced props before!


Some guy in the desert
I decided I had to do a quick aerial video test again using my quick and dirty mount and old cell phone:

Bad jello...but overall a lot sharper than it was before. Really can't wait to get this thing tuned in and build a better camera mount!


Some guy in the desert
Well, busy weekend...but I had to sneak in some time to try the quad somewhere with more space and see how the upgrades went.

Except it was windy this weekend too. 10-15 with 20MPH gusts. :(

Oh well. I had to try anyway. So Sunday I went up to the park - it was more crowded than usual for a Sunday morning so I didn't have as much space as I was hoping for. But there was still some open area away from anyone else...even if the wind was a little stronger than at my house....

First battery was only at about 90% when I started since I had used it for a few quick tests at home...but flew the whole battery with no issues and had a blast. Went back to my truck to pickup a second battery and a dad and daughter had just pulled up and were interested. So I talked to them a bit about how it works and they followed me out to watch it fly. 2nd battery did great. The quad fought the wind wonderfully. I did try the position hold and return to home with mixed results. Position hold wasn't doing so hot...and the direction the wind was blowing was in a direction that I didn't have a lot of room to spare - so I decided to come back to that on a calmer day. RTH seemed to work...but again the wind was blowing me off course in a way I didn't like so again I decided to try again on a calmer day or a place with more room.

I should also note that I was having some issues with my bluetooth again. I fixed the signal wires, but now I'm having an issue with the positive wire not staying plugged in :( Nothing major, just need to solder a new pin on it. But between that and the wind I wasn't able to do much tuning - just some fun flying on stock settings.

The girl was fascinated by the quad and her dad took this opportunity to explain to her why being a geek or a nerd is a good thing since it means you get to build cool toys like mine. I chose to take that as a compliment ;) But by the end of the battery they were ready to go play on the playground and headed off.

So having flown through my 2 newest nicest batteries with no issues despite higher winds than I though I'd be comfortable flying in I decided to strap the old cellphone on again and try one of my 3 older batteries.

Battery was reading 98% so I hooked up my beeper, rigged the camera, and went out to fly. But as soon as I was about 20 feet off the ground my battery beeper started going off. I had raised it from 3.6v to 3.7v since the last few packs I flew until it beeped took about 2180mah and were reading <10% when it went off at 3.6v and I wanted a bit more headroom. (The first two packs both ended up reading 14% and taking about 1800mah on recharge after being flown to the 3.7v point which I'm much happier with and wasn't a drastically different flight time...the beeper now goes off about a minute before my TX timer instead of a minute after the TX timer.)

Landed and checked...battery was reading high still...but one cell was dipping low when hitting the throttle which was setting off the beeper. It had been balance charged on it's last charge...but that was a week ago and the pack has been through some hard landings. Swapped to it's twin...and same basic thing. Plus at this point my TX started beeping that it's battery was due for a charge :( I checked my one last 2200 pack....but it was only reading 15%...doh...though I had at least but a storage charge on it after the last time it was used :(

So. My first two newest batteries did great - I just didn't get to do any tuning and much testing due to the wind and bluetooth power wire. Next two I did get about 8 minutes of aerial footage between them and it is up on my youtube....but I'm not even going to bother linking it because it's horrible. Camera was aimed too far down so you mainly just see grass, and the flights were basically just me taking off...the beeper going off...and me landing - wash/rinse/repeat.

But on Sunday we hit a friends photo studio to do some family shots and I got to talking to him about the quad. He ended up loaning me his emerson 720p actioncam to try out. It's no gopro but it's super light so it will be easier to balance than my old cellphone. I'm hoping to rig some kind of isolated mount for it over the next day or two and see how it does....


Some guy in the desert
It's just been windy windy windy this week. And I've been busy busy busy. So very little chances to fly :(

Plus the android app for tuning MW just released a beta that includes waypoint navigation and I joined the beta - but the beta version is crashing on me as soon as I open it. So even if it wasn't too windy out I can't easily tune right now (Unless I leave the beta or wait for the next update. Thankfully the dev had been updating every other day or so lately so I suspect it will be fixed soon.)

But I have that Emerson 720 action cam from my friend and have been itching to try it out. So I gave it a worst possible case test today:

This was with old dinged and totally unbalanced props, two motors that aren't 100% tight on their mounts, and the camera just zip tied right to the frame with just a 1/4" piece of high density foam between it and the frame. Given all that...I'm pretty impressed with how well it did!

I'm thinking tonight I'll remount the two loose motors (maybe try warming the zip ties as suggested in another thread.) put on some fresh balanced props, and give this another try at the park tomorrow. I'm still leaning towards picking up a mobius but if I saw one of these locally for <$40 like my friend did I just may have to grab one! Even with it's protective case it's 20g lighter than my old phone :)


Some guy in the desert
Ok, time to come clean. The wind isn't the only reason I haven't made much quad progress this week. A new project has stolen my time for the week. It's not really multirotor related so excuse me for sharing it here...but I know a few people enjoy the DIY aspect of my thread and this fits in...and it is flight related so hold on for a few minutes. If you'd prefer skip to the end of the post and I'll share some more test video from the quad today ;)

The new project is a large format plotter! I've been putting off building any more fixed wing craft for a few months because a friend offered me this plotter - but has been dragging his feet on actually making the transfer of ownership happen. Well, earlier this week he finally said "Come get it at lunch today" so of course I did:


It's an early 90's era HP DesignJet 600. B&W only but capable of 24"x33" prints since it uses 24" roll media. If I can get this bad boy going I'll be able to print out FT plans on one sheet! But there will be some challenges. The plotter is old, it only has serial and parallel - USB wasn't even a dream at the time this thing was built. It does have a network card though so that's promising. HP hasn't released drivers for it since Windows XP...but even Windows 7 has stock drivers for it built in. It's also in rough shape. It's been sitting in a friends bosses shop for who knows how long and was covered in dust and looked like it may have had something splashed on it at one point :(

I did some initial cleanup on it and tried to power it up...it made it most of the way through the initialization but then flashed an error about the window needing to be closed and gave a system error 010001. A bit of work on google turned up a service manual and I found that sure enough error 010001 means something is wrong with the window sensor. Tried to figure out how to get to the sensor...but no luck. Thankfully the service manual had good instructions on disassembly/assembly as well!

When I got the end cover off the problem was apparent. Something had been living in here. Or at least storing food in here. It was packed with old dog food! No bedding or feces which I normally see when a mouse has moved in...but one or two spots that looked like urine stains. Fun. Got all that cleaned up and noticed that the ribbon cable connecting the front panel to the main control board was damaged. 4 wires on it were broken. But with the work on the quad I've gotten quite good at soldering ribbon cable so I cut out the damaged sections, soldered in some new wire...and sure enough the window sensor worked again!


With that fixed I tried to load paper. After almost an hour of trying and failing repeatedly I finally read the manual. Yep...it should be sucking the paper in and isn't. Few more diagnostics and it's confirmed...the media sensor isn't responding. It's wires run in the same general area so I was pretty sure I knew what the problem would be. Took the covers back off and sure enough it looks like whatever was living in there went in and out through the same hole these wires ran though and eventually broke them against a metal edge. Took a bit longer to find the actual media sensor since it was about 8" away and the wires to it were totally missing. Eventually I found it and it looked ok...but only one leg still had any wire with insulation on it so I had no idea which wire went to which leg:

(Look close above the repaired wires and you can see the broken media sensor wires)

1514164_10151774401451805_1375974487_o (1).jpg

Did some more googling but couldn't find any photos of the sensor that would let me figure out which leg went to which wire. Did find that the sensor is just an omrom part available for <$8 new...but if you buy it from HP it goes for $50-$100! Then I found this site: http://www.myolddesignjet.com/ and contacted the owner to see if she could help me figure out which wire went to which pin. She replied back very quickly and was extremely helpful. Sent me two sets of photos of a stock sensor showing the wires.

Wired up a new harness...and after a few tries I was able to get paper loaded!

Now I just need ink. It won't finish initializing until it can adjust the pens and it can't adjust the pens without ink. So I've got to wait a few days for some ink to show up (carts are still available but not locally.)

Fingers crossed that when I get the ink I'll be able to get it to plot...and crossed even tighter that I'll be able to get the computer to talk to it and actually send a PDF to it!

Now...back to the topic.

This morning I got to go up to the park for an hour or so to do some flying. Went fairly well. Did a test with the actioncam again and despite some horrible jello from my non-issolated mount it did pretty well:

After that things went downhill though. Hit a few trees, landed in a mud puddle, had some batteries that set of the beeper way sooner than I expected....but still got some nice flying in. Even started feeling more comfortable with acro mode (just not with the camera on!)

Really need to build a better mount.

Came home and got lunch with my wife and daughter...then while they went to the park (ironically the same on I flew at earlier) I got a few more minutes. All of my 2200 packs were in need of a charge at this point so I decided to try a 1500 for a change.

Worked really well. My 1500's are almost half the weight of my 2200's so it was a bit harder to get it to balance with the cam - but without it it felt great! Pretty sure I'll be using the 1500's when I finally start trying some real acro moves down the road ;)

Even so I was able to do some more adventerous flying around the yard - I even made it through the carport which is something I'm pretty hit or miss with on the x1 still:

On the last 1500 I finally started adjusting my PID's. Was able to turn the P up almost as much as I had to turn it down before and still haven't gotten any wobbles yet. So that's promising.

I did try the position hold and RTH at the park and was fairly successful. The position hold doesn't hold as well as I'd like even with 11 sats locked on, wind still tended to push it fairly far away over time. But in general it held. And RTH definitely seemed to work...but I didn't like the quad flying itself since there were some other people at the park even if they were fairly far away.

Can't wait to get out to the desert again for some more intensive testing...still a few weeks before I can do that though :(


Some guy in the desert
No time for the desert today. But I did get to make a quick trip to the park to drain a pack.

Camera mounting is still horrible. Still just two zip ties and a bit of foam - though I did add some silicone tubing around the zip ties today just for giggles. I also put on fresh somewhat balanced props.

Overall it flew great - well enough I even got brave enough to try a few passes under the little pedestrian bridge. Pretty windy today though so it was tougher than I expected and I lost sight of the quad longer than I expected as well which was scary. (and even scarier watching the video and seeing what I missed!)

Got to put a few more packs through it at home too doing some PID tuning. Something is still not right with my BT module after the big crash in the desert a few weeks ago and I keep loosing connection between it and the MW. But I was able to do quite a bit of PID fine tuning today, P went up a bit more before I started getting wobblies. I I've gotten up quite a bit higher and haven't gotten any ill effects yet, and D went up a few notches as well. It's really feeling nice in the air now and very responsive!

Still have a few issues with my magnetic sensor - from time to time it just kind of freaks out. I suspect it's interference from the ESC's. May look at moving it away from the other sensors....

Looks like I get to spend my Christmas bonus on some FPV gear too. I could order the Transporter setup today...but I think I'm going to wait a few weeks and try to save a bit more so I can get the Predators...getting excited either way :D


Some guy in the desert
Decided to fly a quick pack over lunch in the front yard and my wife was actually home for once and offered to video. So a little LOS video of the quad after the tuning I did yesterday.:

Little goof at the end there, something got reversed between my brain and the sticks...decided it was better to sacrifice the quad than risk my wife not moving out of the way. Thankfully nothing broke but bit rough of a "landing" :D I did fly the rest of the pack after that but she was cold (it's only 67 here today and windy) and decided to go back inside ;)

Wasn't very fun flying today though due to the wind. Most of the time I was just trying to fight the wind to stay where I wanted to be. Didn't run the pack until my beeper went because a few minutes later the wind picked up even more and at that point it just wasn't fun to fly in such a small area any more.

Still tuning in the PID's a bit - but my BT stopped connecting for some reason yesterday and I haven't had a chance to figure out why yet.

Also finally remembered to remove my old throttle lock from the mixer - I re-assigned that switch to be my aux4 so I can switch headlock mode on and off...but when I tried it the quad cut power and fell from the sky. oops. Turned out I didn't totally remove the throttle lock after all. (I had it setup two ways, through the mixer and as a safety switch) With that removed I was able to get it going again. But man do I have a hard time flying with headlock. It's just so unintuitive feeling to me I keep giving incorrect input. Can't believe it's supposed to be easier.

Really dying for some time to go out to my desert flying site and have some real fun with it now that it's flying so much better. May even get my nerves up to try a flip again. Yesterday I enabled an option in MW that gives a bit of throttle with tilt to help compensate - haven't really noticed a big difference from it though. Still want to try the acro trainer mode...but don't have a computer I can drag out to the field and that's a change that requires a reflash. Hopefully Christmas afternoon I'll have some time to try it at a local park.
Last edited: