• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XuGong V2 Pro Non-Functional Video Switch

#1
I'm hoping someone out there has both encountered this problem and found a solution for it.

I'm setting up a new XuGong V2 Pro with a NAZA M, an ImmersionRC VTX, and a FrSky X8R receiver and upon assembly I discovered the video switch is non-functional (the one feature of the PDB I didn't test first!).

As per the instructions I have the video switch assigned to channel 8 (its default) but the switch fails to respond to inputs. My Taranis is setup exactly as shown in the ImmersionRC manual but the video never toggles between the FPV camera and the GoPro.

I even tried assigning the channel to a pot. so I could sweep from 988us but 2012us (note that channels 1-7 are assigned to the NAZA M and are functioning normally.) Also tried downgrading the firmware from v1.3 to v1.2 with no luck.

Thankfully the OSD is working and video from the FPV camera is being passed cleanly but the video switch is completely unresponsive.

I tried contacting ImmersionRC support directly as well as posting on their forum but so far I've had no replies from either.

My setup:
NAZA M v2
ImmersionRC 600mW VTX
FrSky X85 connected via SBUS
Taranis Plus TX
Foxeer XAT600M FPV camera
GoPro HERO 4 Black