• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

AM8 With Arduino Ramps Controller Bed Heating Issue

Michael763

Well-known member
#1
Seeking recommendations. I have updated my Anet A8 with two MosFET to an AM8 and changed to an Arduino Ramps controller. Everything is working except my bed temp, it has not got above 54 degrees since the upgrade to Ramps. I have the original Anet 12V bed with 14 gauge power leads soldered in place and a 4.8mm Mirror on it, it heated and maintained temperature fine before upgrading to an Arduino Ramps controller.
I tried Autotune multiple times "M303_E-1_C8_S60" and got a time out each time. I was hoping to change the PID settings to see if that helps. Currently they are set at the default of bedKp 10.00,_bedKi .023, bedKd 305.4. I have done multiple searches on the web, here, and YouTube to no avail. I don't know if I am using the wrong wording or just not seeing something obvious. Any positive help would be greatly appreciated.
(I did ask for help in a Facebook group, but they couldn’t get past the thickness of the mirror. My thought is it worked before the upgrade so why is it an issue now?)
 
#2
I may have only just scratched the surface on detail knowledge of the different specific Arduino/Ramps combinations, but I can still chime in with some electronics/regulation system knowledge, so my 2 cents worth:
How do you measure the 54 degrees? By separate thermometer, or is it a readout value from the arduino? Makes a ton of difference if we are to try to figure out where your problem might lie.
Which ramps version? There are several versions out there, 1.4 apparently being the most often seen. And each version may have it's own specific issues. With the original 1.4s there's some stuff regarding some wrongly placed thermal reliefs on GND ,12V and 12V2(Supplies for the Heater/fan outputs), that limit the max power handling capability, and also may cause some voltage drop at high current. Some of the various clone boards appaently can have other similar varying layout flaws or issues. You can read a bit more about it on https://reprap.org/wiki/RAMPS_1.4. I doubt it to be the main problem, though it might be worth a try to physically measure how much the peak output voltage on the heater output drops under load(You'll likely need an oscilloscope to measure this). Also do check if the output actually is at 100% "PWM", i.e. is it on all the time when it stops at 54 degC, or if it is regulated to a much lower value.
Another thing to check for is if the thermistor type you are using (I would assume you moved it over from your old control setup with the heat bed?) is the same kind the Arduino firmware is set up to expect? See https://reprap.org/wiki/Thermistor for some info. On how to set this up in various flavours of firmwares, I have no idea.
 
Last edited:

kilroy07

Well-known member
#3
Do you still have the MosFETs in place? (I’m assuming one for the bed, the other for the nozzle.)

The other thing to check is resetting/verifying your bang bang settings in marlin are at 100%
(One thing you might look into later on, is upgrading to 24v, everything will be much happier)

Is the location drafty? If it’s colder where you are at now, it just might not have the amperage to get any warmer.
How long did it used to take to get to temp?
Have you tried setting it for preheat and just letting it sit? (Or does it time out there too?)
Tried it without the mirror?
 
#4
For the timeout when running M303, take a look at the WATCH_BED_TEMP_PERIOD in configuration_adv.h - try increasing it to 127 (from the default of 60). Otherwise I agree with the other posters - don't connect the bed directly to the RAMPS but instead keep using the MOSFETs you used with the original board. The self resetting fuses on the RAMPS (the big yellow things) are known to be pretty marginal for the power levels used by a heated bed so the amount of current getting to the bed might not be all it should be.
Also, check the MOSFETs on the RAMPS itself (the black things with a metal tab that sit up vertically) and make sure that the tabs aren't close to touching. I've seen several instances of issues where those tabs were touching that caused weird behavior like the bed overheating whenever the cooling fan turned on.
What version of Marlin are you running (I'm assuming you're using Marlin, right?).