APM 3.2.1: not enough data points to calibrate the compass


That's what I get when I try to calibrate the compass. Actually that's why I bought whole new board, because I couldn't overcome this problem with the old one and thought it's faulty, since I did cut the jumper on it, to disable the internal compass so it uses the GPS one.

Now I have brand new board, I haven't cut anything. Tried with both connected to outside compass+mag and without it. It always says "not enough data points to calibrate the compass"

This is driving me crazy.

I have the micro HKpilot full set from HK and using APM planner software on linux.


Winter is coming
Hey Donnut, sorry to hear of your frustrations, and sorry if these are obvious questions, but did you configure the compass correctly in the software? For that, you need to basically setup the APM as a APM 2.5 with internal compass and set the board rotation (well, technically, you can set it for any rotation, but the navigation might be wonky if it's wrong!)

Also, I've found the internal compass to be a little sensitive to EMF so if you are inside with lots of strong sources or metal, you might need to try the compass calibration outside. More details here: http://ardupilot.org/plane/docs/common-magnetic-interference.html

Lastly, even without calibration, you should be able to see the values coming from the compass over i2c on the apmplanner status window. I don't remember if you have to enable advanced mode or not, though.