• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Dragon link v2 bind problems

Flite Risk

Well-known member
#1
DJI Flamewheel airframe (Hex)
DX18
Dragon link v2.
Naza 32 FC (dont know what version)

Dont know what version of the Dragon klink software in on either RX or the TX. That will be next on my list (where can I find a TTL?).

This rig was given to me by a dear friend who could not figure it out and though I might be able to. I've tried and tried. Tabled it. And am back to it.
Blinking lights, that's what I got. That's all I got. (see the vid)

The DX18 has had a power supply hack (who ever put this together knows what they are doing) but that makes me wonder how the bind process happens when compared to the process without the power hack, the whole hold the momentary bind button power on thing.........
So do you hold the bind momentary, plug in the 1/8" trainer port, then switch on the DX18?
do you hold the bind momentary, Turn on the DX18, then plug in the 1/8 trainer port?
The DX18 seems to get power when the 1/8" trainer plug is plugged in.

Here is a video I just took with lights a blinking, let me know if there is a specific sequence you would like to see me get on video.


Thank you to all contribute,
Chris from Delaware
 

Flite Risk

Well-known member
#2
more digging, this is what I found:

As described here
at minute;3:16
pins 5&6 jumped, properly powered.

I get 3 L.E.Ds. operate in this fashon;

red constant on
greed fast blink for about 2 seconds, stays on until blue is finished
blue fast blink for about 2 seconds, slow flash once
both blue and green go out simotaniously, red still on

See the video here


Thank you to all who reply.
-Chris from Delaware