• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Help! Eachine wizard x220s will not respond to sticks after being armed.

#1
Hello! First time quad human here. I've spent a few hours trying to find this issue resolved before posting. I got my taranis qx7 bound to my receiver on my eachine wizard x220s. The control inputs are appearing in betaflight just fine. I can spin up the motors using betaflight to speeds above and idle but when I take the quad outside, bind the transmitter and arm the quad my motors just spin at an idle and do not respond to any input. I can hear the quad responding to my auxiliary switches as well. I have video output to my goggles as well. Any idea what I could be doing wrong? I did have to disable the accelerator to get my quad to arm. (the mode icon would not turn yellow in the mode menu). Sorry if this is a repeat question. Thanks for your help!
 

"Corpse"

Well-known member
#2
Welcome to the Forums!
Is your maximum throttle set to 2000? If it is too low you won't be able to exceed that.
I can't think of anything else. I haven't seen that before. Also, you should not disable your accelerometer. For the quad to fly smoothly you kinda need that.;)
 

FDS

Well-known member
#3
Also check your channel order in Betaflight matches your transmitter, AETR for FRsky. You also need to check you haven’t enabled stick arming and that your arm angle is set to 180 degrees.