Eachine Wizard


New member
I bought the eachine wizard x220 (regular not s) last Thursday... It is my first real racing fpv quad so I assumed I’d be terrible. I got it flying last night and pretty much just hovered for 7 minutes. I then went inside to make some changes (not PID tuning cause I’m not that ready) but I switched to dshot300 because I had interest in flip over after crash mode. I wake up this morning to a fully charged battery so I go iutside to fly. I arm the motors and they all sound fine but when I push up on the throttle it has the slightest little push and hardly gets off the ground. I am now stuck flying less then an inch off the surface and have no idea how to fix it... please help 😂😂


Wake up! Time to fly!
Since you changed the esc protocol a throttle calibration is required.

Turn on your radio. Set the throttle stick to full. Plug in the quad battery and as soon as you hear tones start drop the throttle stick to lowest position. The escs will reboot and everything should be back to normal and calibrated.

Just do not leave the throttle at full too long after powerup as you could put the escs in programming mode thus opening a whole new can of worms.


Eternal Student
One of the benefits of DSHOT is that it doesn't require throttle calibration. The calibration procedure @PsyBorg posted will work for planes, but for quads you have to do it through the motors tab in Betaflight. Too much time in plank land Bill?

@NoobieFlyer, can you post some screenshots of your configuration and receiver tabs?