• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

First Time quad build. Can't get my KISS 32 flight controller to connect to my Mac.

#1
Hi Folks,

I'm new to the hobby and was really hoping to take my quad out for its first flight ever today, but unfortunately I can't get the firmware flashed to my new KISS 32 flight controller. I can't even get it to connect to the KISS GUI stand-alone app on my Mac running Mac OS Sierra. The USB connection method never shows up on the connection type drop-down menu. I only get the KISS WiFi option and two Bluetooth connection options. I connect the USB micro cable from my laptop to my flight controller and the green power LED illuminates on the flight controller. The status LED never illuminates. I'm aware that you have to be careful that you're using the correct type of USB cable to send both power and data. I've tried two different USB micro cables without success.

This is so frustrating! I'm dying to get airborne...

What am I doing wrong? I verified with a multi-meter that I don't have any shorts between solder connections on the KISS flight controller. I haven't seen the status LED illuminate yet so I assume that the flight controller still needs to verify itself before I can load the firmware. I just can't get a USB connection initiated regardless of whether I try to do it in the GUI app or with Mac OS Terminal commands.

Oh, I forgot to mention that I've already gone into Mac OS Terminal and installed X-Code, installed Homebrew Packet Manager, installed the DFU Tool, downloaded the latest KISS FC firmware (V1.1RC6), and attempted to activate DFU mode. However when I do this I get an error message in Terminal that says "dfu-util: No DFU capable USB device available". I've attached a screenshot of the Terminal window when I do this. I just can't seem to get past this point.

Can anybody help me with this?

Thanks!

Screen Shot 2017-03-19 at 5.01.35 PM.png
 
Last edited:

PsyBorg

Wake up! Time to fly!
#2
I am not familiar with mac as I use a pc but the drivers used to talk to FC's can be finicky. If you are having problems connecting via usb uninstall your drivers. Then plug in the FC and let the computer re choose the proper one. Hopefully mac is smart enough to do that.

I know on my win 7 machine I had loaaded DFU and had the same issue. I found the virtual com port drivers and loaded them and still got no where. When I unintalled the drivers and plugged it back in the VCP driver was reloaded and worked. I was perplexed as to why it did not work side by side with the DFU drivers but if it was loaded first it would.. Computers.. ya can't fly without em and you can't kick them until they submit and comply. Who knew.
 
#3
Thanks for the response, but unfortunately the Mac doesn't just automatically detect the KISS 32 and install drivers for it. And there are no drivers that I can uninstall. It's supposedly plug and play. I may try bringing my laptop home from work to make an attempt at doing this with a PC instead. I'll try anything at this point.
 

PsyBorg

Wake up! Time to fly!
#4
I know to use the gui I had to have Dfuse installed. To be able to actually talk to the boot loader and flash anything I had to have VCP 1.4.0 driver installed.