• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

HELP! Betaflight Uneven Throttle Response

Have a custom Martian 2 build using a bardwell F4 FC,

first flight out one of the ESC burned up midflight, replaced it and re calibrated everything in BLHeli Configurator.

In betaflight: using the master slider to throttle up and all motors spin up the same, when switching to my Taranis and throttling up only motors 2 and 4 throttle up and after lowering thr throttle to min, 2-4 stay at about 50% throttle while 1-3 slowly start to spin faster and faster unless I disarm.

Anyone have any ideas what could be going on here?

Bardwell F4
Taranis QX7
XSR reciever
Emax RS2205
Makerfire BLHeli 30A DShot1200 esc's


Fly Angry
If you are talking about uneven spool up or down when sitting on the bench then that is normal behavior mate. The FC is trying to level the quad so it makes a change. When nothing happens it makes another change. It will hunt like that til you reset it by disarming or you pick it up and it starts the hunt again for level. Since you can not be as still as the table the quad will not hunt as far across the throttle range to find level.

The reason it does not do this when you run motors from the gui is that the accelerometers are disabled in that mode.
The problem happens not hooked up to the computer as well. I'm just plugging into BF to see the values as I ramp the throttle up and down and to see if the motors continue to spook up when throttle is all the way down. Being that it's only two motors actually getting full throttle the quad wants to flip over when the props are on.

It's very strange and I'm just lost at what to do.

I've tried reflashing forward onto the esc's but have been unsuccessful- not sure why that is either.


Fly Angry
Yes you are correct. The effects will happen when not plugged into the computer because the accelerometers are active. When it is plugged in and you use the motors tab to run the motors the acclerometers are turned off. That way the FC does not try to level the quad. It just allows the motors to spin up.

Check again and make sure the motors are turning the proper direction. Also run the motors one at a time and make sure motor order is correct as well. Then without props on still power the quad and run the motors with your radio at about 25% throttle. Hold the quad in your hand and dip one corner at a time. That motor should speed up if everything is set up properly. At that point you can put the props on and do a hover test.

Make sure the props are on with the lettering facing up and that the blades are facing the correct way. When you power the quad do not give it any throttle. Let is sit at idle and then slightly pitch forward. It should try to lean forward. Then do the same for the other three directions. If it leans to each direction you use then you are set to do a hover.
more info...

OK, so took your advice, went out and tried to fly and the quad just kept flipping over on takeoff and was having tons of motor spool up and spool down issues regardless of where the throttle position was on the tx.

In BF and BL Suite, the motors seem to work fine through their full range.

So, i switched the quad into Acro mode; and it flies perfectly in Acro, switching back to Angle or Horizon mode and it flips out of the sky and crashes.

Anyone had this problem before? I have airmode and antigravity on in BF, could that be screwing with Angle and Horizon mode. I rarely use either mode unless i lose video signal or something crazy happens but I think i can save the quad before crashing.

Any ideas on how to fix this issue?


Fly Angry
Did you calibrate the accelerometers on a flat level surface? If they default at a tilted angle they will seek that angle on any power inputs.
Yeah everything seems to be fully calibrated.

Finally got it working somewhat correctly by disabling: airmode always on, and slaved it in the modes menu to the aux switch for horizon / angle selection
So basically airmode only comes on in Acro.

This stopped the flipping and motor over speed issues. For now...

No idea why it should matter, doesn't on some other builds I have.


Fly Angry
You sure you are not working with that mismatched Gui / firmware issue? there was a recent change to a new gui and if you try using the new firmware thru the old gui it causes all kinds of weirdness. Make sure it says version 10.2 or newer under the Bee logo.