• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

HELP! Betaflight Uneven Throttle Response!!

#1
I got some problem when using Betaflight and trying receiver, I am not sure how to fix them😭.
First, when I toggle the left stick, the throttler raise so quickly to the limit I set and then become uneven after a while,they coub not even turn off! how can I let it raise up slowly, smoothly and trun off by toggling down the stick.

the picture shows the situation when I toggle the stick to max.
1665110259197.jpg


Second, motors 3 and 4 should armed when I toggle the right stick to right side, the order seems wrong and I am not sure hoe to fix thm. Hope someone can kindly help me with those problem. Thank you.


Betaflight
Taranis QX7
X8R reciever
 

Addicted

Elite member
#2
I got some problem when using Betaflight and trying receiver, I am not sure how to fix them😭.
First, when I toggle the left stick, the throttler raise so quickly to the limit I set and then become uneven after a while,they coub not even turn off! how can I let it raise up slowly, smoothly and trun off by toggling down the stick.

the picture shows the situation when I toggle the stick to max. View attachment 230950

Second, motors 3 and 4 should armed when I toggle the right stick to right side, the order seems wrong and I am not sure hoe to fix thm. Hope someone can kindly help me with those problem. Thank you.


Betaflight
Taranis QX7
X8R reciever
For your throttle: Calibrate the sticks on the TX, then adjust end points and center points to 1000/1500/2000.
Not sure about the motor issue.
 

Liam B

Well-known member
#3
Maybe try using a different model on the transmitter. It could be an odd setting turned on on the radio.

What does your receiver tab look like?
 
#4
I'm wondering if the quad is just trying to auto-level itself. If you angle it differently do different motors speed up? If so, you might need to put it in a non-stabilized mode to make the test seem normal. I think you basically set switch position to not trigger any mode for the non -stabilized mode - I think it's referred to as acro (been a while since I set up betaflight)