• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Hobby king 2.4Ghz 6ch Rx/Tx Help

#1
Hi all,

Does anyone know how to bind these hobbyking Rx and Tx together and what each of the 6 channels correspond to??
any help would be great, I've been fighting with it for just over a day now :)

Cheers.
 

jamiedco

Prop Killer
#2
do you have the correct receiver . there were 2 versions one with a satiate (v1) one with out (v2)
the newer remotes will only bind to v2 receivers . to bind you must put the bind plug into the bind socket in the receiver ,then power it on and the light should flash quickly . once it is doing that . hold the bind button on your remote and power on . once on the light on the receiver will stop flashing and go solid . at this stage power down tx and rx . remover the bind plug then power on the remote . once its on power up the receiver and it should be bound

best regards jamie
 
#3
Hey jamie, I'm sure it's the right receiver as it's the one that came with the transmitter but while saying that I have seen silly things like that done in the past. I managed to get the Tx/Rx bound together finally but now what I have found is that it will not power the motor :-( all the servo's work fine and easy but there is no "start up beep" from the motor or any activity at all in fact.
 

jamiedco

Prop Killer
#4
thats strange . do u have full control of your servos . if so try putting the motor plug into one of those ports . MAKE SURE THEE MOTOR IS MOUNTED AND HAS NOT GOT A PROP ON IT .
 
#5
Yeah Jamie I tried that too, all that happens when I do that is it just keeps beeping and nothing else. The only way to stop it is to either pull it out of the Rx or disconnect the battery. I think I may have just got a dead motor :-(
 

IamNabil

Senior Member
#6
Can you record the steps you are going through, and toss it on YouTube? It might make it easier to help you troubleshoot.
 

Foam Addict

Squirrel member
#7
Is the throttle trim all the way down? Have you calibrated it? Have you reversed the throttle somehow?
Try the first two, though I am certain the first one has been tried. I hope this helps!
 
#8
Thanks Foam, I have gone over the calibration and binding of the units enough times that I can now do it with my eyes closed :p but the only thing that I haven't really checked is if the Throttle Trim was all the way down. I will check that this afternoon and try again.
 
#9
I just want to thank everyone for their input in this matter, it ended up being that the throttle trim wasn't fully down :-( Rookie mistake lol, anyway everything is good now and went for a fly over the weekend.

thanks again everyone :)