• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Issue with programming HobbyKing Multi-Rotor Control Board V2.1

#1
Okay guys so this is really getting to me now..
i have built my R.cexplorer tricoptor completely now and have not been able to fly it for months
because of this silly control board...
i have a avr programmer that i brought from ebay - http://www.ebay.co.uk/itm/230697850818?ssPageName=STRK:MEWNX:IT&_trksid=p3984.m1497.l2649#ht_1764wt_1037 this one..
and have created an adapter as David says to do in his build log using two servo extenders..
i have only been able to download the kk reflash software on a Mac which has in itself annoying but anyway..
so after finally thinking i will be finally able to re flash the board i get this message.. (or something similar)

Error during setting the fuses.
Flashing of firmware aborted.


I have done abit of digging and cant seem to find anything that will work..

so im all out of ideas..

can anyone PLEASE help as i really want to fly..

cheers guys :)
 

colorex

Rotor Riot!
Mentor
#2
I got that message a lot. I switched computer and KKmulticopterFlashTool version and tried and tried and it finally worked for me.
 
#3
are your settings in the flash tool correct for which programmer and what board you are using . i had the same thing once . then i updated the software and it runs perfectly on my win 7 machine .
 
#4
1. Double check that the leads from your 10pin connector are correctly mapped to the 6pin headers.

2. Make sure you are selecting the right version of your KK board in KKmulticopterFlashTool.

3. The programmer you linked has 3.3V or 5V selectable supply to the KK board. Make sure the selector switch is properly switched to one or the other (either voltage should work, but if the switch isn't properly "switched" it may not be powering the board)

Optionally, paste the output of the programmer here so we can have a closer look.
 
#5
does anyone think that it could be anything to do with the avrprogramming cable i have.?

I am at university at the minute so am unable to get any picture up about my problem but when i do i hope u guys can help..