• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
Pumpkin drop event

KK board display ARMED long beep sound

#1
Hello guys, i need your sugest about my kk board.
I set KK board to tricopter, i use turnigy 9x and set to airplane. When i powering KK board and ESC after board boot LCD display ARMED with long beep sound. What the mistake?

2nd question, how to powering Yaw servo on pin 4 KK board? Can use same UBEC i used for radio receiver?

Regards,

 
Last edited:

HawkMan

Senior Member
#3
Since you're using an UBEC I assume you use OPTO ESCs? in that case you need to split the pore out from it and add one tooth middle pin of I would assume motor 5, as I understand that opto ESCs need also need to be food control circuit power so you can't remove the red wire one 2 or 3, and if that's the case 2 and 3 aren't getting any power to the logic side, which might be the long peep.
 

HawkMan

Senior Member
#5
Yes, but the kk board has a separate power rail on M2-6.

So if you don provide power on one of those the servo on M4 won't get any power.
 

gecko242

Junior Member
#6
From past experience, the long beep usually means the channel is stuck at 100%, check your channels are wired correctly ising the receiver test menu...

If the channel mappings are correct, try adjusting the endpoints and such on your radio.
 

helinor

Senior Member
#7
I would have mounted a second UBEC connected to M5 to power the servo. Don´t use the one already powering the Rx/board. The power to board on M1, or from Rx, is separate from M2-M8 for a reason...
 

HawkMan

Senior Member
#8
I would have mounted a second UBEC connected to M5 to power the servo. Don´t use the one already powering the Rx/board. The power to board on M1, or from Rx, is separate from M2-M8 for a reason...
The general idea is that a small ESC with a built in BEC might not provide enough power for a relatively powerful tail servo, or multiple servos. So they use another ESC just for servo power. With a separate UBEC that shouldn't be a problem. And having 2 ubecs removes any benefit of using OPTOs...
 

HawkMan

Senior Member
#11
Explain this please
One of the main points of a opto is saving weight by stripping unnecessary circuitry. On a tri two ubecs may very well be heavier than three ESCs with bec, never mind all the extra wiring and complications. Noise isn't really a big issue on a small mini anyway.
 
#12
From past experience, the long beep usually means the channel is stuck at 100%, check your channels are wired correctly ising the receiver test menu...

If the channel mappings are correct, try adjusting the endpoints and such on your radio.
i thinks any throuble about my radio, i open "receiver test" from KK board menu and "trim" at my radio transmiter, can't setting (aileron, elevator, rudder channel) receiver test to 0 value even maximum/minimum value of radio trim.
try to see "receiver slider" on KK, channel 3 show maximum sliders, while on my radio "display" show minimum. if i set channel 3 to "reverse" long beep sounds.
 
#14
Solved, i get somethink wrong with my Turnigy 9x. Power switch does not work properly, this make broken signal i indicate by mapping receiver. can't set to zero (center), bar receiver indicator always move and can't stop moving even when stick not moving, when i powering transmitter hear little beep sound.
After i turning On my transmiter with properly (indicate by beep sound) my problem has been solved.
i will replace that switch this week end.

Thanks Guys for all suggest.
Regards from Indonesia
 
Last edited: