• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Need Help from the tricopter Gurus!

sbodi4d

Junior Member
#1
Bought all the stuff to build and fly a Bat Bones tricopter. Bought a Turnigy 9XR radio to fly it with. Tried to download Open TX to the radio, and failed miserably. Have an Apple Mac computer, downloaded the Companion 9X software, and the Crosspack AVR software, and tried to download the open TX software. Everytime I try to upgrade the 9XR software, it tells me that AVRdude did not install correctly. I forgot to backup the software on the radio, so now when I turn my radio on nothing happens! Hope I didn't BRICK my radio!!! I have read several posts on forums on how to fix this, but I'm not the best at resolving software issues. One forum talks about opening a terminal in the Mac, and changing the settings, but I tried this, and when it asked for a password I was stumped, despite using a password I found on another forum! I just want to build, and fly my tricopter. It has been a long time since I have flown, but I was pretty good back then. Hopefully it hasn't changed that much, so that an older R/C pilot can not get airborne. I have a Turnigy 9XR radio, just need to get it in synch with the new software. If anybody else has had this problem, please let me know, so I can get the tricopter going!!!
 

Foam Addict

Squirrel member
#3
Ah, my apologies, I just found this!
I got that same message when I tried to flash my control boards, and it turned out to be a threefold issue. First, I had the wrong board type selected, try that first.
Next, occasionally I had the wrong com port selected.
Finally, if I jostled the USB during the flash, it would lose contact and give me a similar error.

I'm not an Arduino expert, but I really hope this helps. I'm sorry you had to wait so long.:(