• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

New Sukhoi-29MM

srfnmnk

Senior Member
#1
I just got the new Sukhoi-29mm from HorizonHobby and am going to be flying it this weekend. Any lessons learned or tips about this plane? I am looking forward to trying out the new modes as I am still a pretty new pilot. Anyone else have this plane?
 

srfnmnk

Senior Member
#2
Well, I took it out for a quick flight today...unfortunately it was quick. Those throws are huge, it will be an amazing plane but I'm going to have to add some expos to it and drop the throws way down at first until i get used to it. The safe/ASX technology seemed to glitch a bit, but it's probably because I don't know how to let a computer fly my plane yet.

Anyway, got it off the ground a few times and wound up losing control, hit the ground and stripped a servo, ugh. It's a digi 13g servo to, like $17. ARG.
 

srfnmnk

Senior Member
#3
Well...that sucked. Just threw $250 down the toilet. On maiden flight the elevators were so far off I was able to control it at first I circled it around a time or two and landed it...To keep the nose level I had apply full elevator. After landing I applied full sub trim to the elevator and that helped but then I changed from precision mode to stability mode and all of a sudden it kept going straight up even with full elevator down. Finally I hit the panic button and it went level but by the time I could even figure out what was going on it was over a forest and it crashed out there somewhere. Wen't hunting for about an hour, no luck.

The part that pisses me off the most is that it wasn't really my fault, the stupid ASX/SAFE technology killed it. I didn't even have an option to actually fly the dang plane. Whatever, not doing any of that SAFE/ASX tech again...I want to be in control of my plane or at least be able to be with the click of a button but nope, not with that tech...ugh just gonna start rambling now...more...so I'll stop.
 
#4
There is a huge thread on RCG about it. Some people are having issues, however, most can be traced back to improper TX programming. You have to follow the manual very closely when setting it up. Also, it sounds like to me your CG was off. What battery were you using? Did you check the CG?
 

srfnmnk

Senior Member
#5
Yeah, i spent an hour on the phone with product support to make sure I fully understood everything and by the end we came to the conclusion that I understood it all.but...yeah...