• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
Pumpkin drop event

No signal from r-xsr from my T-MOTOR TM 2419+ PLUS HD

#1
So i've bougth a 3 inch drone but i can't get any signal from the receiver.
There is a picture:
the receiver is R-xsr, the fc is mamba f405 mini, the drone is T-MOTOR TM 2419+ PLUS HD, and i plug the battery in the drone otherwise the receiver will not get powered
Cattura.PNG
Cattura2.PNG
IMG_20190418_191147.jpg


When i open betsaflight i get no signal from the receiver, nothing moves, i checked the quad, nothing is burned, all the motor works.


I've only unpacked my quad and binded the receiver, i tested the motor and other stuff and it works, but i get no signal.

Did i miss something ??

unboxing
 
#4
Hello, I checked some things, the Rx only powers up when the battery is connected, but i get no signal, I used D16, so I've already tried all the uarts and nothing works.
Could it be something about inverted or univerted sbus signal?
I got this problem while I was making my 3d printed quad and i solved it by soldering an extra cable on the receiver
 

ElectriSean

Eternal Student
Mentor
#5
From the little info I could find on that FC, UART1 is the only inverted UART available. Make sure this is where the signal wire from the Rx is connected, it should be labelled as SBUS on the FC.
 
#6
It works guys, I tried to swith pins, from Sbus to PPM and magically the recevier got alive...
Is it possibile that my r-xsr came in PPM mode as default?
Or maybe i've pushed in an incorret way the only botton on the RX....