• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Phoenix RC ans Spektrum USB receiver not recognized

#3
Perhaps I was unclear. The Spektrum USB "receiver" is designed for this application. I use it for a quadcopter sim that Flite Test reviewed. I can bind my DX6i to it but the program does not see it.
 

d8veh

Well-known member
#4
Did you install the driver? Did you follow the installation instructions? If you think you did install the driver, check in Device Manager whether Windows is using the correct one. If you plugged the device in before loading the driver, Windows most likely will have chosen a standard driver rather than find the correct one.

If you have loaded the driver after you plugged in the device, try unplugging it and use a different USB port. If you're lucky, Windows will then use the correct driver.

I hope this doesn't hurt, but in case you don't know and for anybody else considering a simulator, you don't need to buy anything expensive. The 22 in 1 Simulator cable that you can buy from Amazon for $10 comes with a cable, a USB adaptor and Phoenix 5.5. All you need is a trainer port on your transmitter.
 
Last edited:
#5
It is a Spektrum WS1000. I did pay about $30 for it but I have four Spektrum xmitters. It does work with my quad sim. When I plugged it into the USB port it did install something. Your advice will be investigated.I appreciate your information.
 

Bricks

Well-known member
#6
You have to have a Phoenix specific USB adapter as that is how they control Pirating. The transmitter cord that comes with phoenix has the piece that makes it work built into the cord.
 

buzzbomb

I know nothing!
#11
The 22 in 1 cable comes with Phoenix on the disk and it definitely works. I use it myself, so does Buzzbomb.
Yep. See the thread.

https://forum.flitetest.com/index.php?threads/phoenix-rc-and-ft-models.56476/

Admins, I keep coming down here and posting that link. I purposely put it where I put it, so more new pilots would see it. I didn't want to bury it down here, where only the dedicated look.

Is it possible to leave active it up above, and sticky it down here, and have one update when the other does?
 
#12
Good Morning Folks:
I took your advice and got the 22 in 1 cable which came with the Phoenix disk. I installed it and the USB adapter worked great with my DX 6i and DX7.
I have a minor gripe though. The throttle does not ramp up as smoothly as when I am flying. Any thoughts about adjusting? Also Downloaded a couple FT models but they do not do anything. They just sit there when I use the throttle. I have downloaded the Sportster and the Mini Arrow Wing. Any thought?
Thanks
 

buzzbomb

I know nothing!
#14
Good Morning Folks:
I took your advice and got the 22 in 1 cable which came with the Phoenix disk. I installed it and the USB adapter worked great with my DX 6i and DX7.
I have a minor gripe though. The throttle does not ramp up as smoothly as when I am flying. Any thoughts about adjusting? Also Downloaded a couple FT models but they do not do anything. They just sit there when I use the throttle. I have downloaded the Sportster and the Mini Arrow Wing. Any thought?
Thanks
Assuming you've set up your transmitter in Phoenix and done the calibration make sure the channels are set correctly for what your trans is outputting.

Go to "System" "Your controls" and the transmitter profile that you set up should be selected. On the right, select edit profile. If you are in the "Simple" view, select "Detailed" on the upper right. I turned off all the helicopter stuff. Scroll down to "Fixed Wing" and make sure your channel assignments are correct. Note that the throttle channel is set in both the "General" field and the "Fixed Wing" field.

ControllerProfile.jpg

You can then check to see if Phoenix is recognizing your transmitter inputs on the proper channel. Go to "System" and "Your Transmitter." That'll give a realtime display of the software reaction to your stick input and on what channel.

YourTransmitter.jpg

If you've previously calibrated and it worked, but now it isn't, then re-calibrate. I had to do that when I set up my gear switch. Come back and let us know if anything helped.