Pico BLX Betaflight drivers for user interface...


Posted a thousand or more times
Hey guys.

First to update you on my other thread-HK is sending me a new Rx, and probably a FC too.

Now in the mean time I thought I try updating the firmware on my old Pico BLX. So I followed a YT video about uninstalling drivers etc. so I could flash it, and that worked but now the problem is how to reset the drivers so I can connect it to betaflight!

I used zadig to change the STM32 driver to a Winusb driver, and that worked for flashing. But now I can't connect to betaflight, and all the STM32 drivers I could find for download don't work with windows 10.

So what do you guys use for drivers? Any suggestions for me? ;)



Antigravity or bust...
I just went thru this, almost. I ended up using Linux to flash mine. I originally tried on windows with Zadig, switched to winusb driver and it turned out I still needed an additional driver. That's when I made up mind to use Linux instead. But after I used Zadig on Win7 I couldn't connect in BetaFlight anymore. After closing everything down though (try reboot) and re-plugging in FC it worked again.

If you have nothing to loose and have admin access, you might try this (at own risk). Don't blame me though if this makes it worse. Open Device Manager and plug in your FC and you should see a new item on the list. You should be able to double click it and uninstall that driver. After that unplug then plug it back in and hopefully Win will put the right driver back on. Good luck to you...