• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Plane is to sensitive

#1
Im a beginner, and i ve built 2 planes. A Storch, and a Sea Otter. Both of them seem to wanna fly great, but as a beginner i cant seem to get around how sensitive the planes seem to be. In the mist of adrenaline of the first flight, and the mini panic "first flight". I seem to be "over correcting" the aircraft's, they both wanna "knife edge" at the slightest stick movment, and or gain altitude, or dive with me barely thinking about moving the sticks.

Control Horns are on the highest holes

Servo Horns are the furthest out as well

Im thinking about shifting my linkage on my servo side down to the bottom hole to reduce my sensitivity?

Im useing a basic Spectrum Dxe transmitter, and dont think it has "expo" settings or anything fancy. Hell the manual is basically garbage, and basically no genuine help online for that transmitter, just a bunch of reviews baised on seeling the thing instead of education...

Im great with controllers, and pc simulated flight (i think more to "scale). But these foam planes are just to SENSITIVE! haha
 

Merv

Well-known member
#5
Im thinking about shifting my linkage on my servo side down to the bottom hole to reduce my sensitivity?...I'm great with controllers, and pc simulated flight
Yes, moving to a lower servo hole will defiantly help and should be the first step. Save turn your throws down in the Tx for fine tuning.
The plane in the simulator fly's better because it has a perfect setup. You can make fly poorly if you change things, CG, throws etc.
 
Last edited:

basslord1124

Well-known member
#6
I don't know if it's like this with the DXe but with the earlier lower grade Spektrum transmitters (DX4, DX5) they had low rates and expo already programmed in...you just had to turn it on.
 

d8veh

Well-known member
#8
All planes can be extremely lively if you keep the motor at full-throttle, which is a classic newb mistake. Did you reduce the throttle as soon as you had some height or were you too busy panicking trying to steer it?

You have dual rates on your transmitter. Did you use them? You should set the low rate to about 60%, which will also make the plane easier to control.
 
#12
From what I just found out...you can put expo on a DXe, just use the mobile app.
Thing is to use the mobile app you have to update the transmitter through the usb cable. Ive already bought and tried the phone cable (headphone jack), but it dont work unless you update the transmitter through your computer with the usb... so you can imagine how annoyed i must be sith those cables...

Do you have any sources for me besides the dozens of unhelpful videos on youtube, or out of date web pages... im lost at how to program my transmitter...
 
#13
if that's the case you might be flying really fast as @d8veh said and/or be banging the sticks around and over correcting.
I knew i would regret saying i felt "panic" 😂..

..no.. im flying at maybe 38% throttle (and its still cranking at that). And my stick movments never go beyond 50%. Unless im going really slow and trying to land safely (bushplane deadstick feel)
 
#14
All planes can be extremely lively if you keep the motor at full-throttle, which is a classic newb mistake. Did you reduce the throttle as soon as you had some height or were you too busy panicking trying to steer it?

You have dual rates on your transmitter. Did you use them? You should set the low rate to about 60%, which will also make the plane easier to control.
If you have information on how to set my rate percentage on my DXE without using a phone or computer. It would help tremendously... i think i just need that damn usb cable... smh... (after i bought the headphone cable that dont work unless the transmitter is updated.. smh.)
 
#15
I knew i would regret saying i felt "panic" 😂..

..no.. im flying at maybe 38% throttle (and its still cranking at that). And my stick movments never go beyond 50%. Unless im going really slow and trying to land safely (bushplane deadstick feel)
hmm, are you flying on the high or low rates FT recommends?
 

d8veh

Well-known member
#16
If you have information on how to set my rate percentage on my DXE without using a phone or computer. It would help tremendously... i think i just need that damn usb cable... smh... (after i bought the headphone cable that dont work unless the transmitter is updated.. smh.)
What happens when you operate the dual rates switches? Often they have a default setting of around 60%, so no programming necessary.
 
#17
Im always on low.

I just think foam planes are just incredably agile, and i need to turn so expo on (once i figure that out?), im setting my linkage to give me the "minimum" throw, and just keep figuring it out.

I also think i need to get more then 15ft off the ground (get up like 100ft) and do some circuits up there, cause this low flying is destroying my planes, haha.
 
#18
What happens when you operate the dual rates switches? Often they have a default setting of around 60%, so no programming necessary.
Ive never even tried high rates besides from tuning on the bench, ive only ever tried low rates, and those seem to be 200% more sensitive then what i would like..
 

Merv

Well-known member
#19
im setting my linkage to give me the "minimum" throw.... (get up like 100ft)...
I almost always have my linkage set to low. Only in my 3D planes will I move the linkage from low.
Try to keep it 3 mistakes high, for me that's 200 feet in the air.
 
Last edited:

d8veh

Well-known member
#20
Ive never even tried high rates besides from tuning on the bench, ive only ever tried low rates, and those seem to be 200% more sensitive then what i would like..
You should switch to high rates, then setup the throws according to the FT instructions. When you go to fly the plane, you can then switch to low rates, which will reduce them to about 60% for easy flying. Is that what you're doing? It's a bit unclear.