• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

R and Esc Help Needed!

Bob_Curtains

Master Foam Patch-Man
#1
Hi Guys, need help. Went to the flying field today with my newly completed FT Racer with "the Beef" power setup from Lazertoyz. I have a Spectrum DX5e Tx with a ARE 00 RX. I plugged in the new ESC to the RX throttle input and plugged in battery. Tried servos and working ok. Tried motor and nothing happen. After several min of scratching my head I realized that I plugged in the ESC input into the RX backwards. I disconnected all servo leads, extracted the power pod and tried correctly inserting the Esc lead to the RX and reconnected the battery and turned the transmitter on. Waited and noticed the RX light blinking and the Esc started to beep continuous for a bit then started to do a sequential beeping. Needless to say I looked up on several forums how to resolve and all answers pointed to resetting the Esc to the RX and tx. Tried the full throttle back down to zero throttle and followed Dans recommendation from Lazertoyz to setup the Esc and nothing has worked. I'm at a loss as to what to do now. Any recommendations would be greatly appreciated.

BTW: I extracted the exact same type 30amp Esc from my spit powerpod and got the same exact response. Beep beep but no motor turning.

What exactly happens when u incorrectly connect the Esc input into the RX pins backwards? What would cause it to not work as before? Same RX worked just yesterday on my spit pp. Thanks again for any and all answers.
 

rcspaceflight

creator of virtual planes
#4
To me it sounds like you might have to re-bind the Rx to the Tx. If the light on the Rx is blinking, I think that means it has power but isn't talking to anything.
 

Craftydan

Hostage Taker of Quads
Staff member
Moderator
Mentor
#6
Ok, the slow blinking light on Spektrum RX's is a "brownout detect". it'll blink like that if it lost power briefly, and by "briefly" it could be 30s or so -- it's what I'd expect after you quickly unplug/plug the battery. A fast blink is the bind light. If you're getting that, something odd is going on . . . unless your bind plug ins still connected to the RX.

Now for the ESC, was it a steady slow beep (about 1 every 2-3sec) or a series of different beeps ( a pattern but not steady)? The first is "I can't hear an RX plugged in", and the second are the steps in the programming mode. troubleshooting for these is quite different.

About my past "recommendation" . . . played with a new ESC last night . . . and it's not the same. In that ESC, you perform the throttle shift immediately after the first beep. Not saying your ESC is like that, but do take the time to read the manual that comes with them -- it's only a sheet of gibberish, but it's useful gibberish . . . sometimes ;)
 

xuzme720

Dedicated foam bender
Mentor
#7
If the ESC was plugged in backwards, you wouldn't have had power to the servos. I think you had it plugged in right to begin with. But then you shouldn't have had power to the Rx after you switched it. I have to admit, I'm flummoxed.
 

Bob_Curtains

Master Foam Patch-Man
#9
Ok, so after hours of research and trying this and that I have come to the conclusion that the AR500 throttle port died. I tried rebinding the Tx to the receiver then switched the port from throttle to ailerons for the esc / bat and I was able to go into programming mode on the esc, I also connected a different servo to the throttle port and got zippo.... Servo just stared at me dead in the water. WTH could have caused the RX throttle port to crap out? I am also baffled at this. Any suggestions?
 

pgerts

Old age member
Mentor
#10
Sorry that you destryed the RX when connecting the ESC wrong.
The power is in the middle and you have replaced the signal (pulses) with the negative.
I have done that by misstake without destoying my RX and you can get the things you say - servos working (kind of but strange and with no real power).
Send your RX to Horizon Hobby and claim warranty... (only telling that the throttle channel is not working) But after you have tried with another RX to see that all is working fine. The first impression i got when reading your problem was that you had the throttle challel reversed. That will give you the startup and then go inte the programming mode of the ESC giving sequential beepings.